Remote control X96 mini

I installed CoreElec on a X96 mini 2G/16G on a SD and got it to work. I also downloaded the remote control files “X96” and “rc_maps.cfg”. Where exactly must they go? Onto the SD or directly into the device? I tried to find the answer here somewhere but could’t find anything specific about that.
Thanks to all of you. CoreElec is great…

Thank you…I have seen this
But is this on the SD card or directly in the machine.

you need to copy them to the device over the network. They go on the sd card, which is unreadable in windows.

if you know the commands you can ssh in, I do not

I use coreftp lite

THX a lot for the clarification. Unfortunately I do not have the possibility of copying something into /storage/.config/rc_keymaps

Same for rc_maps.cfg to /storage/.config.

Is there another location? I added a screenshot of what I see…

I appreciate your help…

It might be a hidden folder. This is my screenshot using coreftp lite

Thanks a lot. I found everything and it’s working well…

Please, someone who has a correct device tree for the new x96 Mini 1g / 8g rom, with p281? the remote control does not work well with the current gxl_281_1gb.

Then create your own remote config, or look for other’s configs. It’s not a DTB issue.

Thanks for answering, surely it is not the dtb?

In other mini x96 with the gxl_212 everything works perfect, but the new ones with gxl_281 fail the remote control. Everything is the same except for the device tree … What is going wrong?

I moved your posts to the relevant topic, please read it.
And read this:

I have managed to run the remote, with the rc_maps for the x96 without changing devicetree. You were right. The problem is that it has a too high timeout and with the command:
ir-ctl -t 20000

Show me:
/ dev / lirc0: device does not support setting timeout

For example: When I press left button, and then right button pulse repeats a left pulsation event, and then the right one

Hi there.
Guys, this might be a stupid question, but are we sure that the CoreElec SD card is supposed to be unreadable in Windows ?
If I remember correctly, with older (at least) versions of LibreElec the card was readable under Windows but it just showed as 512MB or something like that.

I’m asking because when I insert my CoreElec sd card with my card reader to a USB port of my Windows PC, it prompts me to format it (as it is unreadable) and I was kind of worried with that.

p.s. I am able to access the card via SSH (filezilla) and via Windows explorer as a network item.

After burning with rufus, I find the sd auto opens file explorer
So I can see files on win 10

So am I supposed to worry ?
I had checked the SD with HD Sentinel and I had formatted it (FAT32) before I installed CoreElec.
It’s a Lexar Class 10 microSD 16GB.

After burning the CE image you have two partitions. One is accessible in Windows (FAT32), the other isn’t.

I have tried with two different SD cards and two different SD Card Readers. Both cards are inaccessible on Windows file explorer and I can only access them via SSH (filezilla) and via Windows explorer ONLY as a network item when the cards are plugged into the tv box. I can also access them via any file manager on Android. Both cards are Fat32 and have been checked with no issues.

Both CE installation I have done to these cards seem to work without issues.

What could be the reason I cannot access them in Windows with a card reader ? :no_mouth:

Thanks in advance.

Did you perform correct shutdown for box before pulling out SD card?
Also try to perform correct eject for SD card in Android. It must work on Windows.

When I installed CoreElec to the SD card with Rufus (in Windows), in both cases, before I pulled out the reader from the pc I used “Safely Remove Hardware or eject media”.
Other users report that immediately, after Rufus installs CoreElec, Windows explorer is opening (or just able to see) the contents of the card.
In my case (both times, with both cards, with both readers), this did not happen.
So after Rufus I tried to access the card and I couldn’t.

Now, when I inserted the card to the tv box and typed “reboot update” to the terminal emulator, CoreElec run without issues. Then I remember I was not using Kodi’s power / shutdown menu, but I’m using CEC. Shuting down the TV - the tv box shuts down too. Turning on the TV Box, the TV turns on, too.
In my case, I turned off the TV, I waited for the box’s led to turn off and then I pulled the card.
And I do Remember having “shutdown” and not suspend on the CoreElec Cec adapter settings.

A few minutes ago I turned on the Box via the remote, CoreElec lauched. I pressed Reboot to Android, then again Reboot (plain), It rebooted to Android, I went to settings, ejected properly the card and then I pulled it out (be pressing it etc).
Again, the card is not readable / accessible on windows and Windows asks me to format it.

How strange is that ? :expressionless:

EDIT: The card can be viewed / found on Windows Disk Management and also in Ease US Partition Master utility and there are no errors (surface test, etc is issues-free).
OK, I’ve tried with other SD cards, and now it seems that none of my SD cards can be read / accessed on Windows. It must be some issue with my Windows 10.
The cards are readable on a Windows 7 laptop I have…
On another Windows 10 PC (at my workplace) when I first plugged the card reader with the card into the a USB port, it prompted me to format the card, I clicked cancel / no, and two seconds later the card was readable and OK (I could see the CoreElec folder and everything).