Remote is no working on kvim1 CoreElec 20.1-Nexus

Hi, the original remote is not working on:

CoreELEC (official): 20.1-Nexus (Amlogic-ng.arm)
Machine model: Khadas VIM Amlogic dt-id: gxl_kvim

I have tried:
echo “meson-ir * kvim” > /storage/.config/rc_maps.cfg

But it does not seem to work. (this solution worked in older versions of Coreelec)

Can you please help?

1 Like

As written on wiki:

CoreELEC -ng (version 19 and above) can also use the .toml file format.

The whole filename becomes then KEYMAP.toml

   echo "meson-ir * kvim.toml" > /storage/.config/rc_maps.cfg
1 Like

thank you ,I have ran:
echo “meson-ir * kvim.toml” > /storage/.config/rc_maps.cfg
rebooted, but still not working.

Any suggestions?

Try the remote.conf:

work_mode  		= 0
repeat_enable   = 1
repeat_delay    = 130
repeat_peroid   = 120
release_delay   = 20
debug_enable 	= 0

fn_key_scancode       = 0x5c
left_key_scancode     = 0x0e
right_key_scancode    = 0x1a
up_key_scancode       = 0x03
down_key_scancode     = 0x02
ok_key_scancode       = 0x07
pageup_key_scancode   = 0x04
pagedown_key_scancode = 0x1b

		factory_infcode = 1
		factory_code	= 0xff000001

				0 0x0e
				1 0x1a
				2 0x03
				3 0x02
				0x14 116
				0x13 139
				0x03 103
				0x02 108
				0x0e 105
				0x1a 106
				0x07 232
				0x58 114
				0x5c 63
				0x0b 115
				0x01 158
				0x48 102

I have pasted the above on: /storage/.config/rc_maps.cfg/remote.conf

still does not work. any Ideas?

Using rescue-Khadas-Rescue-OS installed
on EMMC and the remote is working.

I also have the Problem that my old toml-File do not work. I got the X96 Max File from the Repo as shown above, but still not working. I got all my codes from the IR Remote listet and controlled and Changed the Codes in the Config File from the Repo and Named it to X96MAXPlus.toml and in the rc_maps.cfg File it’s “meson-ir * X96MaxPlus.toml” but still not working.
Any Ideas what I do wrong?


maybe when you give us some infos…

Hello Portisch,

I Changed back to 19.5_rc3 because the Plex AddOn is not working anymore on Nexus. I don’t want to use the Plex_Agent for Kodi because the Sorting is very difficult instead of the Plex AddOn.
But the Remote also doesn’t work on this Release.
I put the Logfiles and my both Config and toml-File in here for Checking. (89.2 KB)
rc_maps.cfg (27 Bytes)
X96MaxPlus.toml (737 Bytes)

CE_19: coreelec:ce_dev_cycle [CoreELEC Wiki]

Upgrade to CE-20 minimum and make logs again.

As I said, I can’t Upgrade to CE-20, because the old Plex AddOn will not work with CE-20 and I wanted to keep it alive.

Got the Remote working now. I only need to find out how to power it up. My Problem here is finished.


1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.