Remote stopped working since 9.2.3

Hi all

I have a Nexbox A95X, been working fine for quite a while with CoreELEC. I upgraded to 9.2.3 and the remote stopped working.

I had previously changed my remote config to run it from another remote (via Harmony) as the originally remote didnt come with Play/Pause or Menu etc buttons so I changed it to a Pivos xios ds.

The original remote does work now but I am not sure how to get the Pivos remote back. I have downloaded the remote config from the repo but when I check, the original Pivos config is still there.

I noticed the latest changelog states “meson-ir/remote handling changed so no reboot is needed anymore”

How is best to re-instate the Pivos remote scheme back?



I have a different media player (Tanix TX3) but I have also been using a pivos config (for Harmony support also) and I am having the same problem since upgrading to 9.2.3.


I think you have to disable the meson, or rename it.

Then from guide.

Copy remote to storage\config renaming to remote.conf

And copy second remote to storage\config renaming to remotesecond.conf

So, you can have two remotes running using conf

Then name the second file remote2.conf ???

Just checking as remote2.conf is what i use.

rename to “remotesecond” without the quotes

Thanks for the replies. I still cant get it to work. According to the documentation, meson is meant to be default and if you want to use amlogic, you simply need to copy your remote.conf to the config folder. This is what seemingly happened prior to 9.2.3.

It seems to be only using the built in meson settings now and copying a remote.conf file does not switch over to amlogic.

Any idea if this is a bug or does something else need to be done to switch over?


The operation is still the same as it was before.
Default module used is meson-ir. But if you use file /storage/.config/remote.conf then meson-remote is used.

Can you run this command in ssh terminal after reboot and post the url you get?

journalctl -l --no-pager | paste

Yeah sure:

Noticed its checking in /flash/remote.conf

Yeah, confirmed if I overwrite the remote.conf in /flash/ it works again. Seems to be checking in there, rather than /storage/.config/

1 Like

Yes, as you can see remote.conf is used from /flash which is also supported location. And seems file is legit because you can see bunch of lines from remote-config script. So according to the procedure everything is as it should be.
If you don’t want to use this /flash/remote.conf file then just remove it.

The order of checking for remote.conf file is first from /flash then from /storage/.config.

I assume that files been there for years, I havent touched any of the remote settings for many years. I guess the previous versions had a different order of checking.

Well its good to know. Thanks for your help.

Shouldn’t the remote.conf be removed from /flash in the downloadable images? Alternatively, favor the easily accessible location over /flash and use /flash as a last resort.

Given /flash is a RO filesystem, and the instructions say to use /storage/.config as the location to drop your remote.conf file. If /flash is preferred over /storage/.config then it makes it difficult, especially for less experienced users, to use custom remote configs.

I know you can remount as RW but it is far simpler to drop a file into a location exposed as a samba share.

My remote is also working again now by the way, I renamed remote.conf in /flash to resolve it.

Both locations are valid and this is true for some time back and nothing had been changed in this regards…
Yes, /storage/.config is preferred location because it is always writable and easier to use.

I doubt any downloadable image has remote.conf file in /flash. At least I don’t remember any. But maybe I’m wrong. If anyone find some let me know.

care to share how you managed to delete/overwrite /flash/remote.conf?

I am in a similar boat and have been using a what looks to be a Tanix TX3 clone called EgoIggo S95X with a harmony remote with the pivos xios config.
I upgraded from an old libreelec version straight to 9.2.5 and my harmony doesn’t work anymore. … the orignial remote works. Coreelec is installed to internal memory.

I noticed that I also have a /flash/remote.conf file
I tried naming my pivos config /storage/config/remotesecond.conf

And i tried mounting /dev/system as read write, but I always get the device or resource busy error
mount -o rw /dev/system /tmp/internal

From the logs /flash/remote.conf is being used, but there is no mention of remotesecond.conf, so looks like its not used :-/

do not try to mount /dev/system to another folder
instead, just use
mount -o remount,rw /flash
after that the filesystem is writable and I could delete remote.conf
rm /flash/remote.conf