Remote stopped working suddenly

I have a Mecool M8S Pro L.
It was running Coreelec 9.0.2 perfectly.
Both its remote and TV’s remote (Samsung NU8000) were working perfectly.
2 days ago some buttons stopped working on both remotes. I could use arrow key to navigate and cetral button to select, but for example, back and home did not work anymore.
So I checked for an update, I saw that 9.2.0 was available, and I upgraded.
9.2.0 works perfectly (and the red look is gorgeous), but it did not solve the problem.
I also tried to copy again the device tree files, but it didn’t change anything.
Any suggestion about what happened?

Tonight I noticed that stock remote isn’t working at all.
Normally I don’t use it, the one of the tv is better, so now I’m not sure if with 9.0.2 it was working.
For sure it was working when I flashed 9.0.0, then I stopped using it, except for powering on the unit.
So now only TV’s remote works, partially.
I had to use a bt keyboard to go back to home page and shut down.

Have you tried to follow the instructions in this topic?