Replacement tuner for mecool ki pro?

The Digibit itself needs a little bit of config, after that its all done in TVH. I imported the Digibit into my country and there aren’t many users of it here, so it took me a bit of time to figure out the necessary config. There were plenty of guides for Europe etc.

I’m running some custom firmware that adds a few extra features. For me the biggest benefit of the customer firmware is the ability to use one input across all four tuners. I haven’t touched the Digibit config since I installed it. Once configured it just shows up automatically in TVH as a sat>ip tuner and you configure it as you would a PCIe or USB tuner.

I’m not current on the level of support fo the HDStar, I gave up on them a long time ago. I think I had both a v1.5 and a v3.0, the v1.5 wasn’t terrible, but firmware/driver support for the v3.0 was terrible for a long time.

They are saying that a linux enigma receiver is good for SAT-IP transmission for your box where CoreELEC 19 is with Tvheadend. They are saying that satellite usb adapters are unsupported and unreliable that the SAT-IP option is better. After each one does what he wants, if money is spent on unsupported gadgets that are not worth even if he is reporting … I have it clear if I had to buy and I would do it separately for CE 19 ODROID-N2 Plus, Beelink GT King pro , X96 Air, etc and apart for Satellite a Linux deco type Octagon SF8008 (which for Satellite television channels are better than anything else).

It’s not that I’m not listening to your suggestions, in fact I’m considering all of them and studying what enigma2 based machines offer and what the digibit can do. As I said, my main constraint is the old style actuator I don’t want to get rid of, and I fear either solution would need a lot of tinkering to accomplish that.
If the usb adapters are so problematic maybe my best (or less bad) option is to just buy the same board and be done with it, but I’ve taken no decision yet.

I faced the same issue. Despite fact, internal tuner support is discontinued, I bought new one here:

(I am also still on 9.2.x)

Thank you, that’s the shop I found, as well as (same price but more expensive shipping). I guess the new tuner they sent worked?
I think the problem is overheating of the voltage regulator for the lnb, so even if I buy a new one in a few years time it will break.

Everybody keeps saying that dvb support has been removed, but I saw at least one report here that with CE Matrix on a Ki pro dvb works :thinking:

It was not removed. What works will work unless something gets broken. What happened, and was extensively reported here in the forum is that the main (and only) dev for DVB disappeared exactly 2 years ago and there’s nobody left with his extended knowledge.

Thank you, I knew that afl1 went missing before his drivers could be mainlined (I just hope he is well), and I understand that things can break any moment now, but I think I can use it for few years more, at least until the tuner I eventually buy will break again :sweat_smile:
Then I’ll consider if I can get rid of a steerable dish and just put up a pair of smaller dishes for the satellites I’m interested in (I don’t do much satellite hopping these days), or just go the iptv route (though old habits die hard).

If you were from Spain I would give you one of those tuners, I have here several Mecool K1, K2, K3 and Magicsee blocked and broken from friends who sent them to me. I think that these tuners do not break that easy and the fault may be from the electrical components failure board.

I actually live in Spain :smiley:

Oh, and it’s easy to check if the tuner is at fault: just remove the tuner board and if the box boots then it’s the tuner.

Yes, voltage regulator is the culprit. The same was in my old Wetek Play 1 and it also failed here. I expect it will fail again after few years of operation.

New tuner is OK so far.

Send me a private message. If you take care of the shipping I give you the tuner of the Mecool KI Pro. I’m from Andalusia Córdoba, the same you can even come and pick it up.

1 Like

I’d love to but it’ll have to wait until I have some holidays (I live in Barcelona).
I’ll contact you in private for the details.

Cannot help on the actuator, but the Digibit Twin is a doddle to setup.
Plug in your sat cables.
Plug in an ethernet cable.
Plug in a power.
Allocate a fixed IP address for the tuner in your router config or the Digibit config.
Goto your TVheadend setup and enter tuner configuration. Your two digibit tuners will be listed and you just run the standard setup procedure.

There is a possibility that the Digibit doesn’t correctly broadcast its credentials to the network and then it wont show up, the solution is to modify the TVheadend config file to always look for it in a fixed location. Slightly awkward but easy enough.

Thats it your done. As others have said I went through the whole rigmarole of PCi tuner cards, cheap USB tuners. Support was never stable and eventually LinuxTV would always stop supporting your hardware and leave you stranded on an archaic version of Kodi. SAT > IP will always work since its standards driven and the hardware is transparent. Mine has been excellent for two years now.


Update: this morning the box is definitely dead, so I suppose the fault didn’t lie with the tuner board after all :worried:
Now I’m looking for a box with a dvb-s/s2 tuner that works with coreelec and I’m probably out of luck since it seems there is none :sweat_smile:

You are riding a dead horse.

quite, but so there’s no need to tame it :joy:

I have fixed some Mecool for friends, others could not fix them and throw them away. If you have cheap courier delivery and you want to send it … I can see it for you, logically free but if you take care of the delivery.

Thank you, but I wouldn’t want to waste your time. Now, if you could tell me what components are possibly failing, I could take a look myself.

  • The first symptom was the original power supply (12V 1A) broke
  • I had a spare 12V 2A and that worked for a couple hours
  • I tried without the tuner board and it booted
  • I stupidly cut the power supply pin of the INN8186 thinking it was the culprit (since the area around it got very hot in a few seconds), no change
  • It worked for 3 or 4 days with a 12V 1A power supply.
  • Tried again with the 2A power supply, no joy

Both power supplies are fine.