Report about Amlogic S905X4 HK1 RBOX X4

Vasco, I ran your code and this is what I got. Problem of my TV not showing HDR. To be noted, I have an X905X3 and the same video shows HDR.
Vasco: “Please run the video and post the output of dispinfo
You can also run dmesg -c and dmesg|paste after pressing play”

Here is the logs from my HK1 Rbox X4.

That is useful to know since I was debating whether to buy another X3 or get a X4.


I think that may mean there are model variants that support DV (there are various sub-variations of S905x3 and x4s I believe). There’s also the matter of enabling it and licensing it with Dolby I believe?

Yes,.I have a S922x variant that supports DV. It’s not supported in CE though.

Here is a test and image with the PR from @7Ji included to add JL2xx1 support for the 4.9 kernel.
So anyone what have such HK1 box with this gbit LAN SoC try this image if 1gbit connection get established than.

Just place the tar in the update folder and reboot.

1 Like

I tried this on my x96_x4 (mentioned device above already),
and now i get LAN connection, and an IP from DHCP, but somehow it is unstable,
and opened connections get lost, maybe because of failing error correction.
I cannot even open ssh to box from linux laptop, it get stuck after entering password.

LAN works well on Android tho.

So any idea @7Ji?
When the issues are solved we can merge the PR.

The stmmac driver is loaded the same on my S905X3 box and other users’ S905X4 boxes, but there seems some differences on how the driver actually work on them. Maybe S905X4 has different MAC part from S905X3?

Now I’m even not confident on the PR as a whole, maybe it even only works on my box and not on any other boxes? I can’t quite get this solved as I don’t have a S905X4 with JL2101 nor other S905X3 boxes besides my HK1 BOX with JL2101.

You will need to make debug images with the other users to solve the driver issues, that’s how we solve such issues.

These “cheap chinese” boxes come same like all the other X… boxes what we preach again and again to not buy such hardware…

Maybe the Generic PHY driver does not play too well with S905X4, can you try the official JL2101 driver from JLSemi?
Follow the instructions in my last comment in the PR (this link should point you to it), you should be able to unbind the PHY from the Generic PHY driver and bind it to the precompiled official driver.

I tried that now too, and had exactly same error as emveepee:

[  308.384279@2]- net eth0: failed to get the device driver module
[  308.384285@2]- eth0: Could not attach to PHY
[  308.384288@2]- stmmac_open: Cannot attach to PHY (error: -5)
[  525.671799@0]- net eth0: failed to get the device driver module
[  525.671806@0]- eth0: Could not attach to PHY
[  525.671808@0]- stmmac_open: Cannot attach to PHY (error: -5)
CoreELEC:~/backup # lsmod | grep jl
jl2xx1                 20480  -1
CoreELEC:~/backup # ls -l /sys/bus/mdio_bus/devices/*/driver
lrwxrwxrwx    1 root     root             0 Jul 25 13:36 /sys/bus/mdio_bus/devices/stmmac-0:00/driver -> ../../../../../../bus/mdio_bus/drivers/JL2101 Gigabit Ethernet
lrwxrwxrwx    1 root     root             0 Jul 25 13:36 /sys/bus/mdio_bus/devices/stmmac-0:07/driver -> ../../../../../../bus/mdio_bus/drivers/JL2101 Gigabit Ethernet
CoreELEC:~/backup # ifconfig -a
eth0      Link encap:Ethernet  HWaddr 90:0E:B3:44:29:81  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:225 errors:0 dropped:0 overruns:0 frame:0
          TX packets:78 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:44138 (43.1 KiB)  TX bytes:29350 (28.6 KiB)

lo        Link encap:Local Loopback  

CoreELEC:~/backup # lsmod | grep jl
jl2xx1                 20480  -1

Afer loading driver (3. Inset the module into the kernel: insmod jl2xx1.ko), the connection was still unstable, (cannot ssh to box on LAN IP), so i disabled LAN in CoreElec GUI System Settings to restart it, but then it could not be re-enabled, this causes error code shown in dmesg.

I modified the official JL2101 driver once again and now it can be loaded without any error on boot or during userspace. Can you try this test image to check if the network now works on S905X4?

There’s both the update tarball and full generic image, both should work. If you can test both that’ll be much appreciated

@7Ji it does load the JL2101 driver instead of GENERIC PHY but it still initializes with the bogus MAC and doesn’t work

The MAC address is provided by another part of the hardware in SoC itself and my modifications didn’t touch the MAC-related stuff other than that stmmac delay. The MAC address on my HK1 RBOX X4 with a Realtek PHY is also faulty (all 00 for the last 4 hexes) but it works, I guess it’s a common issue for the box/SoC. It can be worked around with some ifconfig commands.

As for your problem about how to make it work other than the MAC part, I don’t have any more ideas :confused:

@Kill_Bill I’m more curious if this will improve the performance and make the wired ethernet at least usable when the Generic PHY driver can drive it but is not usable. Can you also try the test image? If this works for you then there’s at least some of the S905X4 boxes that can benefit from the official driver.

1 Like

My MAC shows 4 zeroes but even 02:0E:00:00:00:00 the 0E is wrong. I still figure we need to wait for kernel 5.4

Mine X4 MAC is 02:21:00:00:00:00 under CE and 02:ad:… under Android. This does not stop the network from working, though.

I tried new jl2xx1.ko driver now on same image installation as before (portisch tar file update to 19.5 from 24 jul), and now i can down eth0 and up again without error.
(that was CoreELEC (community): 19.5-Matrix_devel_20220724143615 (Amlogic-ng.arm))

But connection is still very unstable. I cannot copy file to samba share on box, and often ssh to box fails, same as before. So there is also another problem how the driver has to initialize the hardware or something.

Will try the whole image later.

I flashed image (CoreELEC-Amlogic-ng.arm-19.5-Matrix_devel_20220728001259-Generic.img) , but there CoreELEC configuration / settings Addon is not working “not ready”, but is needed to setup ssh and WLAN network. Since LAN is still not working properly, it cannot be installed, doesn’t find online repo.

Well, i restarted box without LAN cable attached, and now the settings Addon worked, and i could make initital setup config.

But LAN connection 1Gb is still unstable, and for example as i tried to copy some screenshots from smb share on box to notebook, the connection got lost.

I really got no idea how to make JL2101 work on S905X4 now… Everything expected to work all however broken on these boxes…

But I have a method to get rid of the boogus MAC address, put the following content as a service file under /storage/.config/system.d, e.g. /storage/.config/system.d/macsetup.service

Description=Setup correct MAC address

ExecStart=/usr/sbin/ifconfig eth0 hw ether write:your:mac:address:at:here


And enable it: systemctl enable macsetup.service
Then reboot, the MAC address should be whatever you define it. Tested to work on my HK1 RBOX X4 with Realtek PHY