Report about Amlogic S905X4 HK1 RBOX X4

Ok, this will be hopeful helpful. Will check it when I get more time

1 Like

Can you please run this on 5.4?

It also looks like the JL2xx1 is found but it’s not up like it was before with the error I fixed. More debugging is needed for this.
But try to fix WiFi first

udevadm info /sys/bus/sdio/devices/* | paste
output: http://ix.io/4bcX

Thx, please also dump android DTB:
https://wiki.coreelec.org/coreelec:devicetree

Than I can compare it next week

use the command:

dd if=/dev/dtb | gzip > /storage/backup/dtb.img.gz

dtb.img.gz (18.7 KB)

@tomergam please try with this dtb and check if something is starting working. Also make a new dmesg log again please
sc2_s905x4_4g_1gbit.dtb (65.7 KB)

no wifi or ethernet
using usb-ethernet to got the dmesg
http://ix.io/4bgn

I have no idea now, I think without being in touch with the hardware it’s not possible. Can you setup a SSH connection so we can connect over internet to the device?

yes, I can arrange ssh connection.
please send me private message.

@tomergam can you please make a dmesg from android?
When you boot into Android and insert a USB memory it should be able to write the dmesg to this device.
Maybe command su is needed in console to be able to make a dmesg log. Or somehow by a APP or ADP usb debugging.

yes.I will try tomorrow.

By the help of the user @tomergam it was possible for team CoreELEC to finish up a Amlogic-ne 5.4 generic image where WiFi and JL2xx1 Gigabit Ethernet. Please use sc2_s905x4_4g_1gbit.dtb for this device.

Please feel free to have a short test of the new era CoreELEC image:
CoreELEC-Amlogic-ne.arm-20.0-Nexus_devel_20220927092151-Generic.img.gz

Remember: Upgrade from Amlogic-ng to Amlogic-ne is not recommended! Please use another spare boot media to not interfere with the old installation.

2 Likes

HK1 RBOX 1Gb Lan:
lan (JL2101) have the same problem: gets IP by DHCP and disconnects after a few seconds
wi-fi (HK5235f) works
log: https://paste.centos.org/view/a750bf2d

Try static IP, maybe this helps. I guess this JL2xx1 chip is just shi%$§.
Also try with Android if it’s same, if not please make a Android dmesg log.

With static ip the same Up/Down loop.
on android lan worked.

wifi (HK5235f) also have problem - very low speed (on CE19ng) 40-45Mbit cannot play films with big bitrate, but on Android ~200Mbit. I am using external wifi (RTL8821CU), and have ~200MBit on CE.

Ok, I will prepare a new test image tomorrow.

nice, 1Gb lan on X96 X4 works now

This great news. I have a faulty HK1 X1 and I believe HK box quality are very poor. So X96 X4 would be a great alternatives since the gigabit lan works now.

So here a new test version of Amlogic-ne with kernel 5.4.
Gigabit is now working with JL2xx1 chip on HK1 box.

Please feel free to test it:
CoreELEC-Amlogic-ne.arm-20.0-Nexus_devel_20220928121048-Generic.img.gz

1 Like

I was happy to come back from vacation today to see the new kernel with potential JL2xx1 support. Unfortunately it does doesn’t seem to be working any better for me. I don’t see the source yet to the other patches for the JL2xx1. It still doesn’t get the MAC, gives a 169 IP or a non working IP.

http://ix.io/4bGQ

I also cannot use ifconfig eth0 up it says resource busy