RetroArch Kodi add-on for CoreELEC

Hello, thank you so much for this addon!!

I am using it with S922X (Odroid N2+), and tried some games with flycast. All games had immense graphic problems (half of the screen has no texture, most polygons that are flying around belong to something bigger that is not displayed) and were therefore unplayable.

I was able to solve this by replacing the libretro core .so-file with the one from the last previous release, where the cores where updated.

Thanks again for all your efforts!

P.S.: Also (fresh install of 1.6.2) PPSSPP core does not load for me, when I select the core nothing happens and the bottom left text says no core is loaded (after downloading the assets from the online updater). I solved this by replacing as well. Sorry that I cannot help more in assisting with this than noticing

Edit: Solved my “flycast not working”-question myself and changed it into a note.To be clear, Dreamcast and PSP cores run perfectly fine now.

Not sure why the “out of the box” / fresh install behaves like this (dreamcast and ppsspp not working) “for me” (apparently (maybe) since no-one noticed this here so far).

Thanks a third time for the incredibly cool stuff here :heart:

Thanks for the feedbacks, ppsspp and flycast will be fixed in the next upcoming release.

1 Like

v1.6.3 available here or through updater.

  • Update RetroArch to 1.15.0
  • Update ScummVM core to latest
  • Fix PPSSPP missing libzip
  • Fix Flycast graphical issues (revert to last working version)
  • Added Simplified Chinese translation, thanks to @VergilGao

H, thanks for your work. I am trying to use it on Odroid N2+ and CoreElec latest stable.
I have a problem where my Mouse and controller that is recognized by Coreelec and working perfectly there does not work in Retroarch. The controller (Logitech Rumblepad II) has no working buttons in Retroarch, my Mouse (Logitech M720 Bluetooth) has the mousewheel working in all directions, but no buttons, so I can’t choose the online update.
As I cant select the online-updater, I want to try to build the addon with the INCLUDE_DLC option, could you specifiy how and where do I add the option, i.e to which command? I am a beginner with building stuff :wink: Thank you!

I think in your case quickest way is using a keyboard (or a remote controller if you have CEC) to configure gamepad and mouse the first time in retroarch.
Anyway if you want to build the addon with DLC included:

git clone --recursive
cd retroarch-kodi-addon-CoreELEC

But you may need to configure those devices anyways if their mapping is not recognized automatically by retroarch.

Hi, I just updated the add on this morning. I’m using the new coreelec omega alpha 1. Just wanted to report that it goes to boot and causes my device to reboot.

Can you provide more detail? Previous version was working with coreelec omega alpha 1? It’s an Amlogic-ng device?

Yes, it has a s905x rev d. 2gb memory and 8gb emmc. I have coreelec on a 125gb micro sd. I upgraded from coreelec 20 nexus to omega alpha 1. (Not fresh install) just the upgrade .tar file. I went to start your retro arch add on that worked for me in 20. When it started it said it was upgrading to newest version before start. Upgrade to new version completed successfully and proceeded to start. Screen went black and my device reboots coreelec. But you say the newest version worked on omega. I’ll do a fresh install of the add on to see if that works. Thank yog

I’ve not tested the addon with omega yet, but that crash should not depend on the new addon version, nothing has changed system side.
What is the output of retroarch.start -v through ssh?
Also please provide logs as described here

Working perfectly on tx3 mini (s905w).
Thanks for the excellent addon.

SMB is not working for me.

CoreELEC (official): 20.1-Nexus (Amlogic-ng.arm)
Machine model: Le Potato
CoreELEC dt-id: gxl_p212_2g_lepotato
Amlogic dt-id: gxl_p212_2g

My Samba server is running SMB protocol 3.11
So if I don’t select the correct protocol version in the addon settings:

# retroarch.start -v
mount: mounting // on /storage/roms failed: Operation not supported

If I select SMB protocol 3.11 in the addon settings:

mount: mounting // on /storage/roms failed: Permission denied

I can connect just fine with my SMB credentials using smbclient:

# smbclient -U share //
Password for [WORKGROUP\share]:
Try "help" to get a list of possible commands.
smb: \> ls
<list of roms>

If I try to mount the Samba share manually:

#  mount -t cifs -o vers=3.11,username=share,password=<REDACTED> // /storage/roms
mount: mounting // on /storage/roms failed: Permission denied

I’ve tried rebooting and reinstalling the addon. Not sure why my Coreelec doesn’t want to mount a share. Any ideas?

Samba server log shows:

reject request to share [Games] without encryption or signing. Disconnecting.

So SMB protocol version 3.11 seems incompatible with the default samba server’s requirement for encryption/signing. Even the built in mount.cifs command fails on 3.11 so there might need to be a warning/hint that the server may need to disable some defaults.

The SMB protocol version “3” is INVALID. It should be “3.0”

But “3.02” is listed and does work.

Hi, thanks for your feedbacks.

Both “3” and “3.0” are mentioned as valid options in mount.cifs documentation, and both options are reported in the addon settings drop down list accordingly. Maybe the “3” is applicable to some specific configuration, no issue in retaining it in the list as long as the “3.0” is there as well.

Thanks. It does work with either “3.0” or “3.02”.
I had trouble finding documentation and this thread mentioning “retroarch.start -v” helped a lot since I could not find the logfile.

Now I just need help playing games. The blue interface for retroarch is dated and it is not intuitive on which core to select for which ROM. Still figuring it out. Is there a better UI that can be enabled?

It looks like you need to download assets, go to retroarch menu > online updater and download assets and other stuff as needed.
Then you can chose different menu drivers from settings > User interface > Menu.

You can start here

v1.6.4 available here or through updater.

  • Add joypad autoconfig asset to default build
  • Update ScummVM core to latest
  • Add Slovak translation, thanks to @jose1711

If anyone can help/provide some suggestions for a fix… I am able to run the addon just fine and navigate menus through CEC-enabled remote. As soon as I turn on a bluetooth-enabled gamepad the menu navigation is impossible (both remote and gamepad). The only workaround I have is:

  • have gamepad turned off while inside the menus
  • first run a game, then turn on gamepad(s)

Thanks for any hints, jose

It looks like a BT controller configuration issue, does it work properly within kodi? What happens exactly with the RA menu?
What kind of controller is?

Now I did a test with controller started before launching the addon.

== Scenario A: BT controller is off, RA addon is started ==
Turn on BT controller, while RA menus are shown - input from remote and controller are totally ignored (as described before). BT controller must be turned off to reacquire the control over menus.

== Scenario B: BT controller is turned on while in Kodi (where it works also), RA addon is started ==
All seems to be working fine.

Controller is 8bitDo SN30 pro.

You can try again scenario A launching RA manually from SSH with retroarch.start while in Kodi, and see what is prompted when you turn on the BT controller.
Also enable DEBUG level in retroarch logs and check if anything is there at the same point.
I would also try while in RA to remove the BT device and pair / trust it again as explained here.

Nothing shows up in console when the controller connects. Inside log I seem to only be getting “info”-level messages:

[INFO] [udev]: Pad #0 (/dev/input/event5) supports 0 force feedback effects.
[INFO] [Autoconf]: 8Bitdo SN30 Pro configured in port 1.