Retroplayer not working on KVIM


#1

Retroplayer is not working on KVIM. Konami code is executed. Select rom under games menu, no pop-up to ask which emulator to select, only black screen and after some time back to the home screen. Also tested with clean install.

In LibreELEC-KVIM-8.90.005 everything works as expected. Konami code is executed, select rom under games menu, pop up with question which emu to use, emu selected and installs, game is launched.

Only tested with snes roms and with all snes emulators.


#2

Try the mrboom addon it should be under games / standalone games. It uses the Retroplayer back end, and should help narrow down what the issue is.


#3

mrboom gives me a black screen. After a minute or 2 I hear some sounds. Probably the game that started. The screen stays black though. If a press the menu button om my remote I get a kodi pop-up to quit the game and some other choices.


#4

Can you try again with a fresh install of the new 8.95.3 release of CoreELEC. Just to make sure we are not trying to fix something that is already fixed by a newer release. There has been updates to Retroplayer and the emulators since the last release of CoreELEC.

Also if you can try a nes game with nestopia and maybe emulation of another platform as well.
That way we can try to sort out if it is all emulators or just certain ones. Some of the emulators use different display modes internally, so if I can see which work and which don’t it can help me narrow down why you are not getting a picture.

And just to be clear, which exact model of the khadas vim are you using?

Edit: About the not getting a prompt to pick which emulator to use. What file extension do your snes roms have?


#5

I do not have KVIM but S905x build and I observe the same issue as roel. I’ve just updated to 8.95.3 and I see only black screen when launching Mr.Boom. After half minute or so I hear some sounds from the game. I have the same problem with other emulators. Nestopia gives me also just sound, black screen. QuickNES and bnes restart whole Kodi, game is not launched at all.


#6

I have a KVIM S905x.
I will try the new coreelec version. I can try snes, nes and scummvm. It’s all i have.


#7

Could you try game.libretro.vram-test addon and let me know if you get a picture?


#8

I tested yesterday evening GBA, NES and SNES games. All the same experience, first freezing, then black screen, then back to home screen. No popups from retroplayer to ask which emu to use.
Didn’t test vram yet, will try this evening.
I also will check if it is possible to replace the coreelec kernel with the libreelec kernel. In github I checked all the KVIM settings from libreelec en coreelec and everything seems the same. As I don’t think they change settings for retroplayer or libretro between the 2 elec’s I assume it has something to do with the kernel (dtb).


#9

I’ve just installed and executed VRAM Test. Again all I’ve got is black screen :frowning: Here is kodi.log (12.5 KB)


#10

Yes, also black screen. When I press OK on the remote I see for less then a second a checkered board in the middle of the screen.


#11

@roel That’s helpful, do you also see the checkerboard in the previews when changing the rotation or shader settings, from the retroplayer menu. Can you provide a log file as well please? Also here is an Open-Source Nintendo game, extract the chase.nes from chase.zip (69.0 KB) and see if it asks you to select an emulator when you try to play it. (you will most likely still get a black screen, this is just to check what is happening with you not getting the dialog to pick an emulator core.)

@Goliash I appreciate the log file, however it would be more helpful if I had the complete log file, and not a snipped out chunk that doesn’t even contain the full run of the addon.


#12

Yes I see them underneath the retroplayer menu. The menu is translucent and I can see the checkerbooard. It is as big as the menu like it is the background of the menu.

Logfiles:
kodi_crashlog_20181008210901.log (64.5 KB)
kodi.log (72.7 KB)

In kodi.log I can’t find something about retroplayer or libretro. In the crashlog it seems it wan’t to draw the menu to chose the emu, but it gives a error on opening the savestate.


#13

Ok, I have an Idea, what might be a possible cause of the black screen issue. Will make some changes and make a test build for you to try.

It’s a dinner focused holiday weekend(Canadian Thanksgiving) here, and it’s a little after 4 local time so might take me a bit to get to it.

In the mean time can you try the old 8.95.0 image and see if the problem occurs with it as well.


#14

I’ve restarted CoreELEC, turned the debugging logging on and opened Chase.nes. On dialog I’ve chosen NEStopia emulator and got black screen. Here is full kodi.log (73.9 KB)


#15

Has anybody had any luck getting Retroplayer working on Coreelec? I tried it on CoreELEC 8.95.3, and it goes to a black screen and then boots back into kodi. I would love to get some NES time in. :slight_smile:


#16

It depends on your device. Some devices like the Odroid, almost everything works. That is at least one or two working emulators per game system emulated.

The S912 and some variants of the S905 based devices seem to have a couple of issues holding them back.

I’m trying to determine which devices have which issue, and trying to do so in a way that removes variables such as which roms somebody might be trying to use. So it would be helpful if you did the quick test in the following post and leave a reply there as to what results you got.

https://discourse.coreelec.org/t/retroplayer-testing/