Retroplayer Playstation 1 / PSX Emulation


#1

As of the 8.95.0 build of CoreELEC Retroplayer is in pretty good shape. However some of you might be having some difficulty getting Playstation 1 / PSX emulation to work.

To start with you want to be using the pscx rearmed core, and make sure you have the bios files scph5500.bin, scph5501.bin, scph5502.bin placed in:

/storage/.kodi/userdata/addon_data/game.libretro.pcsx-rearmed/resources/system

The bios files can also be placed in the same directory as the Playstation games. The emulator will complain about missing bios files, but it will still work.

Since kodi can’t yet tell the difference between bin/cue files that contain music and bin/cue files that contain playstation games you will also need to add the following to you advancedsettings.xml file to let kodi know not to try and play the bin/cue files with the video or music player:

  <videoextensions>
    <remove>.bin|.img|.iso|.zip</remove>
  </videoextensions>
  <musicextensions>
    <remove>.cue|.zip</remove>
  </musicextensions>
  <pictureextensions>
    <remove>.zip</remove>
  </pictureextensions>

Outside of the games and the bios files that should be everything you need to use the playstation 1/ psx emulation on CoreELEC.


#2

Can you explain how you get retroplayer working?

  1. I did the konami code, and the games section appeared.
  2. I installed snes9x addon from the coreelec repositorie. (libretro is a dependency and is also installed)
  3. I made a “roms” folder in the emulator folder and put some .smc files in it.
    4)I go to games -> add game-source -> add the roms folder
  4. Do the settings explained above in the advancedsettings.xml
  5. connect my controller and set it up as a snes controller

Now when I go to games -> roms and select a .smc roms, the system turns back to the home screen. Nothing happens.
Sow somewhere I am doing something wrong…


#3

According garbear this should be the procedure:

“i created “just-in-time” emulator installation to bring the video experience to games. how awful would it be if you had a choose a codec before playing a video?? no, simply find a rom and hit enter. XBMC will do everything possible to automate the process. if you have no emulators, xbmc will install one and then continue launching the game as if nothing happened. if you bail and go to the add-on manager, fart around for a few minutes, and then install a compatible emulator from there, xbmc will recognize that the emulator was installed as part of the game launching process and ask if you would like to continue launching the game. if the emulator wants a system folder, xbmc will ask you to choose one as part of the game launching process. if it doesn’t want a system folder, you’ll never need to worry about what a system folder is. emulator pre-configuration will be a thing of the past.”

If I uninstall everything “libretro” and find a rom and hit enter, i get a black screen and then afterwards kodi goes back to the start screen. In fact just the same result as when I have libretro cores installed. Never seen a popup to ask which emulator I want to use.

I run coreelec from a KVIM maybe that’s the problem.


#4

I’ve had similar experience but I’ve only tried NES and SNES so far.

When I start the game it asks me which emulator to use. Different emulators yield different results, some give me black screen or returns me to home screen.

For SNES try using snes9x (2002), if you get the option to choose.


#5

Retroplayer is still a work in progress. (As is kodi v18 and CoreELEC) Not all features are complete or stable on all platforms. Which is one of the reasons you have to enter the konami code to be able to try it right now.

Unfortunately not all the emulators work perfectly on all platforms. If one does not work try another.
ex/ for snes if snes9x does not work try either 2010 or 2002 variant of it.

That being said there will be some updates soon that will improve things, and some documentation on how to get the most out of RetroPlayer on platforms supported by CoreELEC. This is once I get a chance to do so, however.


#6

I already tried all snes emulators, they all give the same result -> back to home screen. Maybe it are my roms. if I try them with mednafen on my regular linux PC they work, but yesterday I tried with retroarch and they give me the same result as in retroplayer -> back to the retroarch menu.

I checked also my logs on coreelec, although I don’t know with of the logs I have to check exactly, in the kodi log I found a message it couldn’t find rom.sav file. So maybe it’s a permission issue. This evening I will try to run them from a fat32 formatted usb-stick, this should exclude permission issues.


#7

So I tried from usb stick and tested some other roms, but it stays the same.


#8

I just tested it on LibreElec-KVIM-8.90.005 and it works without problems there, so it seems to be a coreelec thing, probably only KVIM related as it seems to work on other devices.


#10

@roel the LE kernel is much newer than the one we use but it has a number of other issues, there is no 1 size fits all solution with the current kernels that are available


#11

Yes, I know that is why I stay with coreelec, to keep the wife and the kids happy.