Rf/Bluetooth remote help please

I’ve just purchased a gt10 pro air mouse remote which is rf and Bluetooth the problem is the OK button does not seem to work with coreelec/kodi. The actual button works as confirmed with windows. I’ve tried the keymap editor add on and it does recognise that the ok button has been pressed but it still does not work.
Am I missing something obvious? Or does anybody know what I need to do to get it to work?
Thanks

-forgot to mention I’m using vim3 pro with latest coreelec nightly installed on emmc

I know 99% of the time cec works but I’ve been travelling a lot lately and sometimes the tv doesn’t support cec hence purchasing a remote

Check this please:

Maybe you accidentally turned on the button that activates the mouse.
Then the mouse works, but the OK button does not work.
Is it really: gt10 pro air
or maybe: Air Mouse G10 / pro / S … ?
https://gogosmart.pro/en/texnika/televizor/periferiya/air-mouse-g10.html

That’s beyond my capabilities, I’m not sure how to do that, I appreciate you helping though

This is the remote I have…

In appearance, it is almost the same remote control model.
For me, you turn the mouse on and off with this button and if the mouse is on, the OK button does not work!
d39b015cc55c90c0136db8ad54585bc3ce224959_2_375x500
I have a different color of the remote control, but I think it’s the same model
G10S Pro Air Mouse

With mine with air mouse mode on the OK button works but the BACK/RETURN button does not work. With airmouse disabled the OK button does not work but all other buttons work

Check the operation on Andrioid …if it is the same then there is something wrong with your pilot model maybe a defect? some defect of the manufacturer / hardware / software?
I have two models with and without backlight. Both work properly … the PRO model is in a white shade and has a backlight, the other is in a brown shade.
But only yours is controlled by: Bluetooth !!!
mine via usb … take a look here:
Aliexpress-remote G10S G10S PRO G10 BT
Ps. one of the buyers describes a similar problem on the bluetooth model.

I have tried windows and android and it functions as expected on both - all buttons work in both modes. Mine has Bluetooth but it also has a rf receiver I’ve tried both methods of connection with the same outcome. It seems more like a compatibility problem with Kodi