Rikomagic RK25 and CoreELEC

Is it possible to install or run CoreELEC on Rikomagic RK25?

If there isn’t any bootloader locked, it should be working, why not? Try it on SD card.

Unfortunately, I tried both with SDcard and USB. Probably the bootloader does not support such a solution. I was uploading a different image to Beelink (same processor) unfortunately it didn’t help either.

Can you post a link to the device page/shop?

Is it Rikomagic MK25?


Can you tell which version you have?

I suggest trying some, if not all, of the other S922X .dtb, even if they seem incompatible, just to see if one works or at least partially boots. I doubt there’s a risk of bricking the box by doing so.

Here is a list with dtb’s and their corresponding SoC supported by CE: CoreELEC - Device Trees. There are several S922X listed.

Some feedback:

  • I have seen older devices unable to read above 16Gb, therefore please ensure the boot media remains within the manufacturers specified size limit. In my experience most of the OTV devices, except maybe some early first generation ones, should be able to handle 2-16Gb (m)SD Cards and USB Flash Drives without issues.

  • Also please ensure all partitions have been removed from the installation media prior to burning the disk image onto it. I have encountered situations where boot was prevented due to an unreadable partition from a different OS.

S922X is SoC type G12B. So flash an CoreELEC image to uSD/USB and look into folder device_trees and take the one matching best.

Yes indeed. 2GB/16GB version.

Thanks for the information. The 16GB Goodram SD cards I used work properly on Odroid N2 +. I also tested 2GB, I also tried image files from this manufacturer. While preparing the SD penalty, I have already checked all dbt files. Is it possible that the RK25 image bootloader may not support booting from SD?

Sure. When the bootloader is locked.

Can you boot to android and use an app to get all the information about your device?

Have you tried the Reboot to LibreELEC Android app with a prepared card? Ive had a couple of devices over the years where that was the only option to get the device to initially boot to CE from a uSD.

It certainly is a possibility, considering the efforts you’ve made even likely. There might be ways to unlock the bootloader, but that would be a question for a different forum.

Yes I have. But after reset it stops on logo Amlogic S922X - original logo when Android starts. I can’t boot to android even after plug out - plug in power cord until i remove SD card - then i can boot to android either

About | FAQ | Terms of Service | Privacy Policy | Legal Notice