Running old versions of CoreELEC

I have seen recently that some people prefer to stay on older versions of CoreELEC, whilst this is something that I frown upon I can understand why people choose to do it especially with the addition of the troublesome Whitelist feature introduced in Kodi recently.

However as users will find our addons repository is incompatible with older versions of CE, we have resolved this by separating addons in our github repository into sub-directories for each version of CE.

Attached is legacy repository zips you can install in Kodi to allow you to install older addons that match the version of CE that you are running. (74.1 KB) (74.1 KB) (74.1 KB) (74.1 KB) (74.1 KB)

To stay on an old version after installing it you will need to disable auto-update.

Add-ons > CoreELEC configuration > System > Automatic Updates > Manual

Be sure to also remove the latest update from your device if it has already downloaded located in /storage/.update before rebooting.


Brilliant. Thank you. I intend to revert 8.90.2 on one box, Mecool Kii pro, because it worked pretty well and because 8.90.3 and 8.90.4 give me a smallish problem and I need to leave one box working well for others to use. This will make that process so much easier. That won’t stop me testing the later versions as I have another box (Mecool Ki pro).

After been stung with various small issues with the 8.90.3 release when it auto-updated I rolled back to 8.90.2
This time I am rebuilding 8.90.4 as a USB from scratch and will test it before doing the final install to internal. So far 8.90.4 looks better than my experience with 8.90.3 so I hope to be migrating soon.what was nice was my VIM2 dTV remote worked out of the box with 8.90.4 which is a nice step forward.


Hello … then probably you need to disable auto-update by default, and then the old version immediately begins to be updated to navuyu …:wink:

Sorry I don’t understand. I have been into Settings/System => Add-ons => Updates and set it to “Never check for updates”. Is this what you meant? Or did you mean the setting on the Coreelec menu which is set to manual to keep it ar 8.90.2? And what is navuyu?

This is another topic post higher …
and you need to install from zip, and then install from the repository, and that’s it …

Sorry I don’t understand what you mean by ‘This is another topic post higher …’

After setting Updates to ‘Never check for updates’, I have copied the to a folder on my Mecool KII and then gone to Settings=>Addons=> Install from zip file, I’ve found the and pressed OK. I immediately get a message saying CoreELEC Add-ons Addon updated.

I can see that it has replaced a folder (repository.coreelec) in .kodi/addons with one that contains the contents of the zip that refers to So that all looks as it should be there.

But when I go to Install from repository CoreELEC Addons is still at CoreELEC - 9.0.0 and Tvheadend HTSP Client is still at and still gives the same error when I try to install it.

When I look at I can see that the file it should be using is but this version hasn’t made it into the database.

Perhaps the links are not right, you need to say about this adamg …
he will check …

I have updated the zips, there was a slight issue with them. Install them via Kodi with ‘install from zip’.

1 Like

Now I get the following errors.

23:38:27.302 T:3956269936 DEBUG: Unpacking zip:// to /storage/.kodi/addons/temp/05a40bf3-0c21-4d7d-89c8-21fdc281d212
23:38:27.305 T:3956269936 ERROR: Failed to unpack archive ‘zip://’ to ‘/storage/.kodi/addons/temp/05a40bf3-0c21-4d7d-89c8-21fdc281d212’

There is an empty folder produced in the .kodi/addons/temp folder called:

this is a problem with your system, as they install successfully here, sorry can’t offer much more advice, maybe try installing from a different location?

Aha! For some reason I needed to copy the zip file directly onto the sd card rather than putting it on there via ssh. Computers! Who’d 'ave 'em? Many thanks adamg, as I say this will be useful for me. And many thanks for all your work on this, done for free for the love of it. :smile:

adamg …
I’ll check later 8.90.2 …

No problem, glad it’s working for you now.

I have installed this repository some time ago to stay on ver. 8.90.2 which was very stable for me.
Now I started thinking about upgrade to latest ver. 8.90.5 which seems to be stable and good overall.

How should I process the upgrade:
1 - remove legacy repository first, is it mandatory?
2 - can I upgrade directly from ver. 8.90.2 or should I install the versions between to be safe?
Thanks in advance

You can upgrade no problem just remove the legacy repo add-on first to prevent any issues.