S905L supported?

Hi. I have X96Q tvbox on S905L CPU. Which image can I download to work with my hardware?

S905L is GXL family, in general still supported by CE20-NG Generic image.
But S905L needs DTB gxl_p211…, which is not available.
You may try other DTBs, but unlikely they will work. You could also doublecheck if it’s really this CPU inside your box.

Thanks. I have checked CPU name on motherboard. S905L exactly.

Do you have experience booting from such a flash drive? Surely it won’t reflash it, but just download it?
There are several download methods:

  1. Android application Reboot to LibreELEC - does not work.
  2. reboot update - didn’t work. goes into a cyclic reboot
  3. Click on the button in the AV port - I want to try, but I’m afraid that the firmware process will start.

Should work with gxl_p281 dtb… unless the device is locked

Tried gxl_p281_2g.dtb - Still cyclic reboot.
I have sdcard created from https://4pda.to/stat/go?u=https%3A%2F%2Frelkai.coreelec.org%2FAmlogic-ng%2Fce-20%2FCoreELEC-Amlogic-ng.arm-20.3-Nexus_nightly_20230908-Generic.img.gz&e=124889440
Maybe I shoud have try another image?

How to define locked or not?
Root is ON.

E.g. if you find the bootloader files with ENC extension in the UBT log while flashing.

The prerequisite for booting CE is preinstalled Android 7.x and higher.
What do you have pre-installed?
Is the 2g RAM really available?

AIDA64 shows 2Gb and Android 9 (Pie)
But free -m shows 989M total

You have EMPC memory (lpddr3+nand or emmc) on the PCB. I couldn’t find the datasheet for it… If you caught a NAND variant, a corresponding dtb for nand or slowemmc dtb is required. Just test it out. Without logs it’s impossible to guess why it won’t boot.

Which dtb of this list CoreELEC - Device Trees you can advise?

I see only one: gxl_p212_1g_slowemmc
use this dtb?

Have tried gxl_p212_1g_slowemmc.dtb - cyclic reboot
Later will try gxl_p212_2g_slowemmc.dtb

List of used DTB files
905L.img (self-created from https://4pda.to/forum/)

With all files (renamed to dtb.img) - cyclic reboot.
What’s wrong?

attach the boot log

where I can find it?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.