S905x not booting Corelec

Hi everyone.
I have 2-3 tv boxes with S905x cpu. All of them have a broken emmc i think because whatever i do and whatever firmware i tried to use, fails at 7% formatting in usb burning tool. They don’t even boot from recovery.
I thought i could boot Coreelec or Libreelec from SD card and still use them.
I tried both of them using all compatible dtb files with no success.
I then tried libreelec specific images for Khadas VIM1 and Le Potato boards (both using s905x cpu) and both boot and are working fine. I then noticed that generic s905x images and those two boards images have different booting files on SD card. On coreelec images, boot files are the same and boxes don’t boot!
Also tried specifi VIM1 and LePotato Ubuntu and Android SD images and boxes boot.
I would like to know, is there any Coreelec image that you think can be used on my boxes (even for VIM1 or LePotato) that use different boot files?
Any help is appreciated! Thanks in advance!

A small update. Tested Coreelec for LePotato image and edited config.ini to show coreelec=‘progress’ so i can see what happens.
The installation gets stuck forever on Checking Disk(s): UUID=xxxxxxx UUID=xxxxxxx