S905X SoC Android 7.2.1 firmware - "Universal" no brand specific

I want to upgrade a couple of s905x devices to Android 7 firmware to enable them to run CE -ng without any potential issues that have reported on this forum.
I have Tanix TX5 Pro and Beelink Mini MXIII II, both on factory Android 6 firmwares.
Is there a guide out there on how to do that?
Edit: my boxes manufacturers don’t provide factory firmwares updated to Android 7 for those two models.
I want to avoid issues associated with the original Android 6 firmwares and CE -ng installs.
I know how to updated them now, the only question remaining is which 3rd party ROM to use.

Thank you

Thanks for the reply.
Sorry I wasn’t clear with my question.
What I was actually asking about is the upgrade from the original factory loaded Android firmware (Marshmallow) to another Android firmware (Nougat).
My goal is to switch to CE -ng.
My boxes are Marshmallow based
And I read that CE -ng is problematic on those (requires Nougat).
Since I’ve posted the question I’ve found guides on how to use the USB burning tool.
Now I need to figure out which Android 7.1.2 firmware to load.
The manufacturers of the above mentioned boxes don’t support them anymore (both Beelink and Tanix) therefore there are no factory supplied Nougat based firmware versions for my models.
I came across the “universal Aidan’s custom ROM”, Android 7.1.2 version which seems to be working on 90% of s905x based tv boxes.
Has anyone tried one?

I still don’t get it.
You install -ng to SD card, just as you would the previous versions, and it should work just fine.
If you want to try and install it on to the emmc, that’s at your own risk, and you can use the ceemmc tool.
I have 2 devices with 7.1 and both work fine with -ng from SD cards.

Sorry, I see I missed that your devices are on 6.0.
I’d just try it from SD card and see if it works or not, before updating anything.

Am I mistaken in my assumption that the -ng doesn’t play nice when installed on the box containing Android Marshmallow firmware on the internal?
As I remember seeing something about the boot sectors difference between Android 6 and 7, and that CE -ng is tailored to work best off Nougat based firmware?
Oh, you’re saying just try first on Android 6.0?
OK, I’ll try that then.

Minimum Android 7 is preferred. It should also work on Android 6 but there can be strange effects like system freeze, reboots or some other strange errors.

But a Android 7 firmware is not a guarantee that also the bootloader is updated in the image…

I think that you might have missed the subtle reminders that the devs here are best consulted on CE issues. Updating an Android box to a later version isn’t something that you should expect them to be any more informed with than you and your good old friend Google search :+1:

I wouldn’t think there will be a guide in CE forums as, each box is potentially different and therefore maintaining instructions on how to flash a new h/w image for every android box would be a bit much to hope for (in a forum that caters for support of an OS designed to run from external media).

In principle, the procedure is simple: Locate the image & flash it (using the appropriate flashing software for that particular device). Which software / procedure to use can be obtained (if it exists at all) by using a search about your particular device. Presumably, if you are able to locate the firmware image you are searching for, that source is also a good place to enquire about flashing the image.

You will find the Tanix firmware under downloads:

For Beelink please go to the Beelink forum:

Unfortunately neither Tanix nor Beelink have bothered to update their factory firmwares for my models to Android 7.
That’s the reason for why I’m considering using a “Universal” 3rd party tv box Android 7.1.2 firmware.

Why would you expect a cheapbox manufacturer to ever update their firmware ? There is no benefit for them in doing so so they simply don’t. They are selling an appliance not a computer. Its time to upgrade this ancient box.


I don’t expect anything, just report my findings and ask a question.
Throwing out a still working and perfectly adequate for my needs box is not exactly my way of doing things.
But thank you for a suggestion though.

Then you have to accept that you are stuck on Kodi Leia. Wasting time on trying to find something that doesn’t exist and would likely brick your working box is a fools errand.

The basic reality is that there is almost no difference in upgrading to Matrix from running on Leia so you box is good for at least another year without doing anything.


That wouldn’t be a big problem.
Bricking the outdated boxes is not a big deal. :grinning:
I don’t think I’ll ever go 3rd party ROM if my boxes take CE -ng.
Just wanted to get some feel on what you gurus suggest.
I really appreciate all the work that you guys have done!!

I understand your frustration @lolight. I think the issue is not with Android 6 but with the box configuration. If you search, the common issue with Amlogic-ng is with 1G RAM configuration. If you have 2G seems they have an updated bootloader version and Amlogic-ng boots up just fine. For the few that does not, they have Android upgrade to 7+ and they then can boot Amlogic-ng.

The issue are the boxes that you and myself have that only has 1G and currently stuck at Android 6.

I tried flashing Aidan’s custom rom and it softbrick my box. I was trying to unbrick it over the weekend and finally found a image that would boot and then I flash it into internal memory.

At least I found a way to unbrick it. However, the task is to find an Android 7 image that will boot up in this 1G DDR3 box which is rare.

Some indicated they were successful in flashing Android 7 on their 1GB box but the image they mentioned never worked for my T95X.

1 Like

Hi i try the same with my old S905 Boxes (V88 and A95x).
I tryed Android 9 Roms.
For me Aidan’s Custom ROM Mi Box Official Firmware Based (without Root) and atv experience (with Root) worked.
But to get WIFI and Remote to work in Android is hard.

1 Like

I use Aidan AndroidTV 9 for the S905x Boxes

This updates uboot, and therefore the ng builds runs great on the following boxes:

yoka TV KB1
Sunvell T95X


@hieppo, what was the image that helped you to boot your soft-bricked box?
Just wonder…


I have the beelink mxiii ii and had the exact same problem with you. can’t say if it works with the other box you ve got, but this solved it for me:

1 Like

For reference sake, here’s a link to that firmware:

TX7 - HQYG-TX7-nikodi-20180104

1 Like