S905X3 disappearing cores


I have the latest stable 20.1 running on a X96 Air (4gb 1gbit version)
using CoreELEC dt-id: sm1_s905x3_4g_1gbit without any problems.
CPU is s904x3 rev c
Let me provide some context:

I’ve used CoreELEC 19.5 and had no problems. I upgraded to 20 when it was released and I after a while cpu usage was high like some memory leak or some zombified Kodi thread and network very sloe, so I decided it would be related to doing an upgrade.
I ended up doing a clean install from sd and then used emmctool to copy it to the emmc.
I also did some upgrades to nightly to see if it fixed it and all was working well until ssh stopped giving me a shell.
It simply closes connection. Searched on the the logs and nothing came up but I was able to send commands via remote ssh, so I downgraded to stable again and ssh worked again.
So, again I started from 0 and installed the stable 20.1.
Now, after sometime of usage I start missing cores. They disappear and It becomes very noticeable.
I tried with both governors available : performance and on demand.Same result.

dmesg | paste after loosing 2 cores:


So, I went and check and on
cat /proc/cpuinfo only cpu 0 and 2 are available.
I also checked and all of the were in governor performance.
I tried to change it via ssh to on demand and all 4 cpus appeared and load went considerable lower.
After some minutes cpu 3 is gone again:
new dmesg | paste

After reboot all is well.
Is my x96 dying ?

I think I have found the issue. and leave it here as reference.
It seems my x96 air on Kodi 20 goes easily to 75 degrees C. and that starts to shutdown cores.
After I’ve directed a fan to the device it is now stable 50 degrees C and the box seems snappier.
Now I need to setup a proper fan instead of a 12000mm (a home fan) directed at it :wink:

the nightly ssh issue I’ll try to do another clean install using a nightly.

Have you checked in the CoreELEC configuration add-on under Hardware if you can set your device performance to “OnDemand”?

The issue was temperature related . Also I’ve changed that option via ssh with weird results because the ui does not change anything for that on my box .

Yeah, encountered the same last summer. Was running some resource eating docker images and CPU boomed with 2 cores left running.
You can use
lscpu |grep Off
to check which core is offline, e.g. it will show sth. like:
Off-line CPU(s) list: 1
then use
echo 1 > /sys/devices/system/cpu/cpu1/online
To turn it on again.
Now I just installed a temperature-triggered fan to fight this.

What’s the fan you use ?
I ordered some heatsinks and an usb powered fan. But I would also like to go the temperature activated fan

I actually had the same problem . Docker and hot days . Also it seems running the gui@120hz heats it also . So 2/3 the same

homeassistant docker (Running on the box, host mode. Don’t worry, this one is not resource eating XD)+iot smart plug (must be supported by HA, like Xiaomi)+DC fan.

Setup HA to feed CPU temperature to an action to turn on the smart plug, then tweak the trigger threshold to your liking. e.g. turn on when CPU >70 C, and turn off when CPU <55 C.

Might seemed to be a bit overkill, but if you use normal temperature-controlled fan, the trigger would be room temperature rather than the box’s CPU temperature, which is inaccurate.

Normal temperature controlled fan has external NTC temp sensor.
I think you could trick the sensor by adding a 100k trimmer poti into the line,
so the fan senses higher resistance and thinks, it is cooler temperature.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.