[s905x3] x96 max plus (max+) issues - stable build, crashes, audio delay on resume/seeking

I’m currently using nightly builds.

Biggest question

  • can I use stable build with s905x3 even if DTB file is only in nightly?
    • Just use stable 9.2.1 with DTB from nightly is possible somehow?
    • I tried stable 9.2.1 -ng with DTB from nightly and system did not even start to boot, no core elec logo etc.

Major issues

  • box crashes and restarts all the time, mostly in UI, i think only once it happened during playback
    • can it be temperature related maybe?
    • At idle it sits at 69-70C (see photo of the “heatsink” and thermal pad (i guess) bellow), running at 1980MHz
    • I think at playback time there is actually less cpu-gpu load because it outputs 24p 1080 or 4k instead of 60p 4k
    • ttps://youtu.be/kYNzUvenoxU
    • ttps://i.imgur.com/FBj1nhF.jpg
    • ttps://i.imgur.com/9oQ4sdC.jpg
    • even after I let it cool down overnight, right after boot i’m at 40C
    • https://i.imgur.com/7hWBlgO.jpg
    • I use the AC adapter that came with the box
    • UPDATE: I noticed crashes&restarts when temp is even at 59C - is there a way to run memtest on s905x3
    • UPDATE2: I did run “memtester 3GB” command, without HDMI cable connected, and it found no issue
    • UPDATE3: I tried the stock heatsink and it was pretty hot after I removed it from the machine while i could keep my finger pressed on the chip, so I guess even thought it does not look like it it is actually well designed, I put the box upside down because of how it is designed inside
  • audio delay when pause/play or after seeking
    • does not matter whether i’m using passthrough or not
    • ttps://youtu.be/4NcTWV3_9Sc

Minor issues

  • No way to disable update (notifications) in nightly
    • I have everything in settings > core elec > update section disabled or set to manual, but still get update notifications
    • I guess this could be solved by putting correct line in the hosts file - what URL does core elect check for nightly updates on?
    • ttps://i.imgur.com/wne5x8C.jpg
  • After crash and restart I get update notification window with changelog after each start up and in breaks up plex plugin autostart
    • i figured out that if i manually restart after updating restart I don’t get notifications after system crashes
    • Also manual restart is needed not to lose any settings change
  • Does not wake up on CEC (ie. input switching on TV)
    • this can be workaround by going to settings > system > (somewhere) > devices/peripherals > CEC - disable suspend/sleep on CEC standby command - so box never goes to sleep
    • well … in my case, because all the restarts it then keeps waking up the tv :smiley: (also can be disabled in the cec menu thought)
  • Disable UI scaling does work correctly - UI it is shown in top left quarter (But plex plugin can put SOME content to the full screen height) - this is after fresh install of latest nighly
    • does not really bother me, movies in 4k work, just that it would be nice to have
  • VFD does not work
    • does not bother me and solution is probably on the forums
      • ttps://discourse.coreelec.org/t/x96max-s905x3-vfd-not-working/8573
  • CEC sometimes take long time to register after startup
    • this might be TV issue
    • this will be solved if I get rid of the constant crashes and restarts with box not going to sleep/power off when it receives CEC standby command - so super minor issue

I have two of these Max+ and yes, they also run hot, around 70C idle too. But I haven’t suffered any of the crashes you have so I don’t think it’s temperature related. Have you tried a fresh install on a different SD card?

That is correct … it cannot be done for nightlies.
These are test images and it is set so to keep everyone on the same image when reporting problems.

No, I thought about installing to EMMC, but I don’t think this is SD card. Is there a way to prove it is SDcard issue?

SD cards don’t have any SMART monitoring capabilities so no, you can’t really prove it. But I’ve had crashing issues before and they’ve nearly always been solved with a new SD card.

Try a fresh install on the same card if you don’t have a new one. Something might have gone wrong in the installation. Unlikely to fix it but worth a shot.