S912 devices with CE installed on the eMMC

Adventures and misadventures of S912 devices with CoreELEC installed on the eMMC.

For two years my M12N and H96Pro+ devices supported all versions of CoreELEC in the eMMC, but with version 9.2.7 they have stopped booting, I repaired them, and they crashed again, up to three times. In the case of the H96Pro+, even the USB flash memory boot did not work well because it did not recognize any WiFi adapter, internal, external, or ethernet.

I finally give up. I have recovered an old Beelink GT1_709N0 ROM with WiFi drivers for AP6255, modified by me in 2018, with the most basic android 7.1 that does not even allow adding a Google account unless we update the Play Store and Google Play Services apps. I used almost the same ROM for both, even though one has 2GB RAM and the other 3GB, for M12N I modified the DTB so that ethernet can run at 100Mb/s, and I was hoping that the Q9377 internal WiFi card from H96PRO+ would stop working.

Now I have two new android devices working wonderfully without any problem, the internal WiFi card Q9377 of H96PRO+ obviously does not work (never worked well) but the external USB WiFi adapter RTL8812BU works wonderfully because perhaps the Beelink ROM includes other drivers besides AP6255.

I hope this experience serves as a warning for those who dare to install CE on the eMMC with old processors S912.

Unfortunately S912 chips are no longer supported in the latest releases. Older versions of CE should still work for the forseeable future.

Shoog

My S912 is running CE 9.2.7. @internal memory.
Audio & Video playback is working fine.
No need to run Matrix on this old box

I have finally fixed the problem. The TV Boxes stayed on the initial screen and Kodi did not start but the system was active, that is, everything worked except the screen. After some unsuccessful attempts (stop/start the Kodi service, change the screen resolution, …) I saw that if I disabled autostart.sh then everything worked again. My solution has been to set a delay of 20 seconds in the execution of autostart.sh, maybe the problem was in my command “systemctl start wireguard” but this does not make sense to me so I am not sure.

In summary, autostart.sh commands can interfere with system startup.

I have taken the opportunity to install CoreELEC without losing Android in a very simple way: Once CE booted from a 2/4GB flash memory, and after using the ssh df and blkid commands to know the names of the internal android partition (/dev/data) and CE partition storage (/dev/sda2) I have applied the following commands:

systemctl stop kodi
e2label /dev/data "STORAGE"
e2label /dev/sda2 "EXT-STORAGE"
reboot

From now on, the STORAGE partition is in the internal memory, mixed with the android directories, and the device flies, although there is always the risk of messing up android by a factory reset in CE, or of spoiling CE by a factory reset in Android :rofl: :rofl: :rofl:

In summary, CoreELEC/LibreELEC are fantastic, it can be started on a device with other operating systems from a flash memory and use as storage space any disk partition, internal or external, named STORAGE.

1 Like

About | FAQ | Terms of Service | Privacy Policy | Legal Notice