S912 running 9.2.6 does not respect 'wait for network before Kodi' [Solved]

Hi Folks,

title says it all, my s912 box installed to emc is not respecting the ‘wait for network before starting kodi’ setting under CE addon network settings. This is not new for 9.2.6, it was also doing it on 9.2.5.

i use a remote SQL so my db does not load. looking at my network port that it is connected to on my router, the led on the port only lights as Kodi gui appears on screen. i have to ssh in and stop/start Kodi to get my DB.

This is not an issue on my CE 19 boxes, or my other two S912 boxes running 9.2.6, the only difference is that those boxes run off SD.

Any idea on what i need to check to understand why this is happening?

Thanks!

I think this got reworked by LE on v19, maybe this is the reason it works there. But I don’t think it will be backported to 9.2.

Hi Portisch,

im an not sure i follow? my other 9.2.6 boxes wait for the network to start before kodi loads, so when kodi loads it can reach mysql over the network, but on this box it does not wait, kodi starts before the network so kodi is unable to reach mysql over the network, only after kodi gui is up, does the network come up by which time kodi has given up trying to reach my remote sql.

is there a way to set a delay in kodi starting after the OS is up that is not related to network? a simple 5 or 10 second delay after CE is up before kodi is started probably would do it…

Thanks

1 Like

Same here on one of my S905x3 boxes (X96 Air). I have to do a restart of Kodi (just Kodi, not a reboot) to make it work.

In my case it is not only the failing connection to the MySQL server but also one of the addons complains about the missing network (Zattoo HiQ as it tries to pull updates for its EPG)

I already increased the delay to up to 15 seconds, no luck.

I am running 9.2.7

so i think i got to the bottom of the issue on this box, and have a work around but it is pretty rubbish and doesnt fit with how i like to have my network set up.

my IP is static for this box, this is due to having a crappy virgin super hub that regularly ‘forgets’ reserved IP addresses. i don’t really want to buy an extra router that has a better DHCP server that will remember IP reservation reliably and piggy back, so i set my DHCP range to start at .100, then any devices i want to have a set ip for i configure as static and use the .2 -.99 range.

If i set my CE box to used DHCP, it waits for the IP to be assigned before starting Kodi, for up to as long as i have set in CE wait for network settings. Everything works. SQL DB is loaded every time on start up.

As soon as i set a static IP, kodi just loads strait up before network is ready, so no DB is available and i have to ssh in and restart Kodi to get my DB.

Strangely i don’t have this issue on my other 7 Kodi boxes that use same sql server and are ‘static IP’, but they are all running CE19, and that aint coming to S912…

now if some kind sole could advise how i set a delay in CE starting Kodi for say 10 seconds after the underlying OS is up, i would be a happy guy!!!

so i got a solution yey!!

create a file in storage/config called autostart.sh

inside the file i wrote

sleep 5

‘5’ is the number of seconds delay before Kodi starts. if it is still not working, try increasing to you find a suitable value

About | FAQ | Terms of Service | Privacy Policy | Legal Notice