[S922X-H] Bee-link GS-King X

ssh root@IPaddress, password coreelec

Beelink IS officially supported in ceemmc.

Thank you! :pray:

But as usual be prepared if something goes wrong. Like how to reflash the Android firmware.

True - CE support.
But there is no support from Beelink.

Maybee we will read about bricked Beelink box next time

Could be. But things like this are always risky. To stay safe booting from uSD card is the only option. You got that anarchotaoist ?

I think it is obviously that there is no 100% guarantee. Or this should be emphasized?

How to do this -reflash Android Software?
I was hoping to do an adb pull and push to restore.
ADB and Fastboot do not work. No devices found.

Coreelec instruction at: How to use the Team CoreELEC ceemmc tool
say to use Amlogic Burncardmaker or the USB burning tool - both which seem to require Windows but I only have Linux.
I did find what appears to be a linux version of firmware installer:
GitHub - Stane1983/aml-linux-usb-burn: Linux version of Amlogic USB Burn Tool

I also found this tool: Burning Tools for Linux PC - Announcements - Khadas Community

Instructions for these are not too clear. Has anyone used either? Is there another tool or method available for Linux?
I also found what looks to be the required firmware:

HopefullyI will not require it!

In any case I have successfully SSHed into Coreelec but wanted to check about restore options before running the ceemmc tool and installing to the internal emmc.

Regarding versions: Corelec on the provided SD card came with 9.2.6 and did an automatic upgrade to 9.2,7.
The upgrade channel seems to have switched from the 9 series to 19.2. I am assuming this will require a fresh install to update to - yes?


Your post is not very clear about what you are trying to achieve. Does your device even boot to Android? I assume yes because it boots to CE.
You can update Android to latest version from Android itself. Or you can create SD card. Using Windows is preferred but maybe Linux can be used too.

Hello vpeter.
I am sorry my post is unclear. It is a continuation of the above previous posts - in which I state that I wish to install coreelec to the emmc.

Mitigation would be a good idea as you prudently suggested:

Yes, the device boots to Android. Yes, Corelec works from the manufacturer supplied SDcard.
I do not want Android -I want to overwrite it with Coreelec.
I was inquiring about Android rom restoration methods available that do not require a Windows system on the possibility that the installation of Coreelec with the ceemmc tool is unsuccessful and the device becoming unbootable.

Thank you for your reply.
I will post elsewhere on advice for Linux assistance if this is required.

For using Linux to restore Android you need to find some other tutorial. I’m sure you are not the first person need that.

What addon can I install on CoreElec to make a network share of my internal hard drives?

At present, is it better to use sharing on Android or on CoreElec? What advantages?

Thank you.

CE comes with SMB sharing built in. This is the most reliable and safest method of sharing.
CE has settings for the Server side SMB in the Coreelec settings addon, and this is where you set your version and passwords.
In general Kodi settings is the client SMB settings and this is where you set your supported version to match the server side.


1 Like

I formatted 2 hard drives in NTFS which I filled with my media, then I inserted them in the TV box and I activated Samba in CoreElec. No worries, it worked. I was able to access my SMB share from another CoreElec and from Windows.

Then after a few hours it didn’t work anymore. I have a message telling me that the device refuses the connection, whether from a Windows PC or another TV box with CoreElec.

SSH works well though. I tried to edit the /run/samba/smb.conf file by replacing # local master = yes with local master = no, but this the SMB share still does not work and every time the device reboots the smb file .conf reverts to the original settings.

In the CoreElec interface, I tried to enable or disable password authentication or the minimum supported SMB protocol but it doesn’t change anything.

Anyone have any idea where my problem might come from?

Just a tought, ip adres the same?
Best to give player with coreelec a static ip

I have setup in my router (R7000) a reservation for my players ip adress

1 Like

You need to edit file /storage/.config/samba.conf.

1 Like

Static IP sounds like a good call. Set it on your router.


1 Like

I think there must have been a bug. I reinstalled CoreELEC and it worked straight away. Thank you.

Yes, and it was squashed to death.


Anyone know how to view your HDD in the GS kings on a PC using a USB cable?

If you cannot find out how to do that directly on GS-King, you’ll have to take one drive out and connect it to a Sata port on a PC, or use a Sata to USB Adaper like this one with dual USB connector for sufficient power supply.

1 Like

Unmount both drives and use e2label to change name.

1 Like