Samba shares from Windows 10 accesible from Android Kodi 18.5, but NOT from Core Elec 9.2.1!


I receive the error message “Operation not permitted” when trying to access samba shares hosted on a windows 10 laptop(HDD connected via USB), using Core Elec 9.2.1 on a beelink gt 1 mini (SN 95x), dtb file “4g 1gbit” something.

The very same windows 10 shares are however accessible when using Kodi Leia 18.5 from the standard stock android firmware (oreo) --> hence it must be a Core Elec bug?

Or could it be the settings I have in CE?
Link to settings pictures:
Samba: activated, Name of group: “Workgroup”, password authentication: no, samba protocol supported: 1 to 3, auto share hdd: yes.
Have tried both wired and wireless connection.
I have CIFS 1.0 activated in windows 10 settings.
Zeroconfig does not find them.

Appreciate very much if you bother to write a reply!


Not a CE Bug.

Not relevant to your Windows Settings which will not allow you to log into the laptop.

You need to use a username and password to log into the windows machine.

I have a router that has Windows SMB sharing for attached USB drives and i had the same issue.
I used file manager to add the router ip address which hard drive is attached as a source.
When adding it as a source i chose password which prompted for a username and password.
I filled them in. The hard drive then appeared as a source.
After that was succesfully done i navigated to System/Media Settings/Library/Videos and added the video source as in your screenshot by using Browse and navigating to the router IP in file manager which i had logged into with file manager. (In your case the Windows laptop IP.), The source should open the hard drive and you can map whatever you want.
Hope i explained it OK.

Hi, thanks for the super quick reply and good explanation!

I actually managed to figure it out in the meantime…It is not CE bug but has all to do with permission settings on the windows SMB shares…so how could it work with Android Kodi but not CE Kodi when all settings were the same?

I believe the answer to that is that the default “anonymous” user(no login/password was used, hence it defaults to the “anonymous” user) is different in android vs CE…

I discovered there were two “anonymous” user accounts in my windows (I have not created any of them myself though): “alle” (meaning all, norwegian), and “guest”. Only “alle” had been granted access to the shares, and I believe Android Kodi defaulted to “alle” as the “anonymous” user and CE to “guest”.

So when I granted “guest” access to the SMB share (in windows share settings), CE also worked :slight_smile:

What also worked was to setup the SMB share in CE with a user that had login/password in (similar to your suggestion).

Now I am very happy, CE works like a dream so far :slight_smile: