Seek works but skip does not

Skip has never worked for me on the C2. I can Fast Forward and Rewind just fine but the extremely handy seek during pause feature (10/30/60sec/3/5/10min…) does not work. On the Pi3 running LibreELEC, the same buttons worked for FF/REW during play and seek during pause.

I had originally installed LibreELEC on the C2 but quickly discovered the many problems the LE C2 build had, so I migrated to CE. Initially, I installed CE and restored my configuration from the LE backup, but since that really is not supported, I did a hard reset, upgraded to 9.0.0 and started from scratch, hoping that would fix the skip problem but no joy.

Remote control is a Harmony 650, and I have tried the HardKernel Media Player, Odroid C2 Media Center PC, Microsoft Media Player (MS A9O-00007), and Media Center PC - MS Windows Media Center. None of the remotes really offer all of the features I would like, such as both go back (backspace) and “Escape” features that work. The “Go Back” button is inoperative.

I’m used to better - I use a cheap Chinavision remote dongle (the remote broke) with the Pi3 and that setting on the Harmony works a treat with it, offering backspace, Esc, and Tab keystrokes, along with perfect FF/REW and skip functions.

Is there a way to duplicate this functionality on the C2 with CoreELEC? I’m concerned that something else is wrong since a friend of mine is running CE on his C2, also with a Harmony 650, and the skip function apparently works fine for him.


- Phil

Ssh into your box and type irw and see what happens when you press the different buttons. Are all the buttons showing something. I think Windows media centre remote should work the best. So, use that profile. What happens when you press the skip button? Do you get any output on the ssh terminal?

197 0 KEY_NEXT devinput
19c 0 KEY_PREVIOUS devinput

If you get an output like this from all your keys, them most likely your remote files have some error in them.

Try pressing the left and right directional keys web a video is playing.


Yep, the aforementioned friend confirmed that the left and right directional keys work as skip keys. So I guess I need to map those keys to the other keys I’m used to using via MyHarmony, or via whatever XML file is used to change the behavior in Kodi/CE if the keys I want to use generate codes by default.

I’ll give the irw command a try… many thanks for the info, I was hoping that there was a diagnostic tool like that available.

Unfortunately, you apparently can’t add commands or keypresses that don’t already exist in that profile (i.e. Backspace, Tab, etc), within MyHarmony, which is a pretty serious limitation. The only application I know of for setting up that remote works over the web, so you can’t do any clever hacking of config files to make things work, as far as I know. If that’s actually possible or there’s another app that doesn’t require you to be tethered to the “Logitech Cloud”, then I’d love to hear about it.

It’s great that they’ve made it so easy to use but it seems that Logitech has dumbed things down too much, I feel like a Linux guy stuck in a Windows world where flexibility is but a dream…

- Phil