... select the "internal player"

Good evening, everyone,

how can I please select the “internal player” in the coreELEC menu, I must always go via “Play with” otherwise no video starts.

Specs; Beelink Mini MXIII, S.905,gxbb_p200_2G_1Gbit_RealtekWiFi, CoreELEC 9.0.3

Many thanks

What kind of files are you seeing this with?

I am using the current CoreELEC version (stable). To play a video, I must go to the selection menu and select the “VideoPlayer”, otherwise the video will not be started.

Do a clean install and try again, this has to be some of your settings/addons.

Could it be a setting in playercorefactory.xml ?

Thank you, yes "playercorefactory.xml " I guess, but I have no idea what I have to change there and how…
otherwise i would edit the "playercorefactory.xml " via ssh.

Try moving it off the box temporarily and then see what the effect is after a reboot.

1 Like

So delete the “playercorefactory.xml” ?
I packed coreELEC on the internal eMMC. I don’t need android (unfortunately Android remains even after copying to the internal memory)
I can of course finish a micro-SD card again.

SSH in and then move it to your PC so that you have a copy just in case it is needed again.

1 Like

I can’t delete the file “playercorefactory.xml” with WinSCP (SCP), because no root/sudo rights.

how do i proceed with putty over ssh ?

You connect to the box as root, there’s no sudo.
So you should be able to delete it, unless you somehow managed to get that file onto the read-only filesystem.

I would suggest that you make a clean SD card installation and boot from it. See how that works, worry about your internal install (which is not supported by the CE team) later.

1 Like

I know that “installtointernal” is not popular.
but please don’t always reply to that.

When I shoot everything, the “usb male to male” cable comes to the box with the scrap Android and the round one starts from the beginning.

The reason why I flashed coreELEC on the internal eMMC, I wanted to compare the read and write accesses to the micro-SD (reader!). In addition, high BItraten ~40Mbits seem to lead to problems…I wanted also therefore a comparison.

Running “installtointernal” via ssh (putty) is not very difficult… but I don’t know how to get to the “playercorefactory.xml”. With WinSCP (SFTP/SCP) I can’t delete the “playercorefactory.xml”.

Edit; I reset coreELEC, that solved the problem.

He is not suggesting that you don’t use “installtointernal” so no need to get defensive.
He is saying run a clean install of SD card and see if the problem persists on that running system. This will allow you to identify if the problem is systemic or localized to you installed system. Once you know that you can work out what specifically is messing up your installed system.

It part of using a systematic fault finding procedure.


1 Like

I understand the logic of the micro-SD card procedure.
Videos could be started directly from the micro-SD card and only then I copied them to the internal eMMC memory.
This should be logical.

Meanwhile the problem would be solved by a factory reset in CoreELEC, and runs well on the eMMC.