Simple box for CE and IPTV?


#1

Hi! I need some recommendations. I am quite new to CE and LE on Amlogic boxes.
I have a MINIX U9-H for media playback, but I need a box to my kitchen TV also. This box will not play movies at all, only IPTV via Simple IPTV Client or TVHeadend. I have no possibility to use ethernet cable on this location, but Wifi coverage is excellent here. Also, 802.11AC and Dual band can be utilized.

So what platform to go for? S905X? Any suggestions on such a box that works good with CE? I guess wifi dual band is a must also.

Thanks in advance!!


#2

Ehm, just realized that I actually have an odd box in deep down in a storage room. A TVIP 605, https://www.tvip.tv/en/media-center/sbox-605, it is based on the s905x platform. Do you think there is a device tree that can be used with this?


#3

The following dtb should work on this device:
gxl_p212_1g


#4

Cool! I will test and report back. Thanks!


#5

Ah, I didn’t even manage to get it to boot from the USB. I tried the different ways that wrxstasy described, but there were not many to choose from as it is not running Android currently, but some IPTV software. I tried both USB ports, but I will also get another micro-sd card to try as well.
I will also check the possibilities to SSH into the box, have no clue about credentials though.


#6

I doubt that more people might be sitting on this device, but if, I will write my findings here for others to use.
I found some instructions on how to get in to recover mode of the TVIP 605:
There are various ways to enter Recovery system:

  • From Android OS use adb tool.

  • From Linux-Qt OS use telnet command reboot_tool recovery .

  • Power off mediacenter, then power it on and press Del on IR remote several times.

  • Download archive http://update.tvip.ru/stb/<model>/recovery_sd_<model>.tgz (<model> is Mediacenter model, like, s410 ); extract to SD-card root; insert SD-card to mediacenter; power on mediacenter. This method works even if internal Recovery system is broken.

I do however not know if Telnet require user/password, but if it does, I have no idea what the credentials might be. I will try the other options this weekend.


#7

I was able to force the box to recovery mode, but it will not accept a usb stick with Coreelec on it, it seems to expect a zip file. I have installed some kind of Android beta version though. I might be able to store the kodi.apk and install it, but it is a very unsmooth solution.

http://sv.tinypic.com/r/2rfrprp/9

I will gladly listen for suggestions… :slight_smile:


#8

No, I don’t think I am able to install CE on this box. It seems to be locked with this Linux IPTV software it came with. Well well


#9

I think if it is looking for a zip file, that is because it is looking for a OTA update.

My mecool doesn’t have a reset button, I tried various, android programs to boot to recovery.

this one https://play.google.com/store/apps/details?id=jackpal.androidterm worked.

so insert your sd card or usb with the CE image & the dtb renamed to dtb.img run the above android app

reboot update

if it doesn’t work, try another device tree


#10

Hi @bubblegum57!
Thanks for the advice. I did as you explained, both using the LE SD-USB Creator tool and also just putting the image file to the storage (of course together with a dtb). But when executing “Reboot update”, I end up in the Recovery screen.

So, no luck this time.

Might it be possible to use ADB Sideload?


#11

Not quite sure what is going on. Download the coreelec img.gz file
Burn using rufus not le tool
After burning you will see a device tree folder select the dtb you need
Copy this dtb to root of image
Rename it to dtb.img replacing one already there
Reboot using app
If it doesn’t boot to CE try a different dtb


#12

Thanks for your patience! This is exactly what I did, but I have not tried other dtb:s yet (pretty sure I am using the right one, also recommendt by @relkai).

Can the box be hard locked to avoid this? It feels a bit strange since it is more or less a S905X box with a different IPTV software


#13

It could be locked


#14

I open the emulator in Android, and type reboot update like this:
http://sv.tinypic.com/r/2dmh3wh/9

Bu I end up in the recovery menu like this:
http://sv.tinypic.com/r/2rfrprp/9

It maybe hard to solve


#15

I can be wrong regarding the dtb, though, and you could try another one.
But @bubblegum57 has a point. Some devices just have a locked boot loader.


#16

Yes yes, no worries. Actually, I had that dtb in mind when looking for a proper device tree.
Well, I maybe need to admit myself beaten, although I hate that! :wink:

Thanks for your support and ideas guys!