Skipping 2 external USB HD on boot?

My situation:
I am using a Minix Neo U9-H with CE 9.2.2.
Over a year ago I installed CE on a micro SD card and I was very satisfied. CE was working fine but the performance could be better, so I used the installtointernal script and removed the SD card.
I have 2 external USB-HDs attached with my media. Now I have a weird effect when booting:
First I could not boot at all, the device tried to boot from the external HD and went into bootloop.
After a hint I marked the HDs as “active” with diskpart, so they would be skipped while booting.
But this works only partially: When I attach only on external HD, CE skips it now while booting, everything is fine. But when I attach the second HD my device goes into bootloop again while booting.
It does not matter which HD is attached, it only boots when only one HD is plugged in.
Is this something I can fix by myself?

Powersupply issue?
Have you tried with active HUB /selfpowered HDD?

easy solution: You know turn normal boot mode through putty you connect to box, and after through ssh send command: “reboot recovery”. Vice-versa, command “reboot update” through ssh run again in sd card boot mode. For more answers, what is ssh, what is putty please use google. Bye bye

Powersupply is not the point, I used the same HDs over years at the same device. The only difference was that I was booting CE from SD card before.

@ atirage21
I’m not really sure what you mean. You mean I have to update CE with itself (the same version 9.2.2)?

  1. reboot into recovery
  2. start a manual update
    This would mean I have to put the correct file into the /storage/.update folder before.
    Is that right?

are the hard drives primary or logical? try changing to logical

That did not change anything, I tried. And I don’t see a reason why it should.
Is there a way to change the boot order?