Slow NFS browsing *only* in source - not file manager

I’ve added an NFS share to “Videos”. When I enter any sub-folder, it takes 10-15 seconds to display the list of files in the folder. Even if there’s only one file.

I can playback 4K videos just fine with no stuttering, so I don’t think it is a network speed problem.

If I go to Settings - File Manager, I can browse the NFS share instantly. So I don’t think it is a problem with my server.

I don’t have the NFS share set to have any content, it is excluded from my library. I have cleared the library from the settings. I’ve manually deleted the MyVideos116.db file. I’ve tried editing the sqlite directly.
I’ve deleted the media source and re-added it.
I’ve even tried rebooting.
Browsing NFS shares from “Videos” is unbearably slow.

Any idea what the cause is? I think it started with the October update, but I’m not sure.

S912 rev A, CoreELEC 9.2.5

I ended up reseting everything to default and it worked again.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.