Slow wifi download speed with usb dongle

Hello, I have a A95x f2 tv box and to connect to wifi I use an external usb dongle tp-link tl-wn823n v1 (driver rtl8192cu). It works, but the download speed is just around 10 mbits , instead if I use the dongle on an old laptop with windows (just an i3 dual core 2.13 ghz with 4 gb ram) the speed is around 42 mbits. The upload speed instead is almost full bandwidth in both cases. Any chance to get a better download ?

This USB WiFi dongle has previously been reported as working by yourself.
Did this slowdown start with a particular CE version ??

To what kind of media do you download, or if you are not downloading but only measuring, how do you measure download speed?

I think from the last 2-3 releases it started going slower, I also tried to downgrade to version 9.2.2 but I still have that problem

I took a speed test with arnubox addon

Bad choice.
You may want to download Speed Tester from OFFICIAL Kodi Repository.

I tried speed tester as well but I have the same results

Is it possible to change version of driver maybe? Do you have any suggestion?

When using the older version you are stuck with the older versions bugs.

“workarounds” such as you mention are just stupid.

I somewhat remember this WiFi issue. What WiFi adapter are you having the speed issues with?

I use a tp-link tl-wn823n v1 (driver rtl8192cu). With 9.2.0 version the download speed is three times faster than the other releases.

Can you ssh into the device and run


while the WiFi Adapter is attached, then post the output here. Just to verify that we are looking at the right driver, since rtl8192cu hasn’t changed, in ~16 months(Well before the 9.2.0 release). So it’s a little odd that there is a difference.

Sure, here’s the output:

CoreELEC (official): 9.2.0 (Amlogic-ng.arm)
CoreELEC:~ # lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
CoreELEC:~ # lsmod
Module Size Used by
tun 40960 2
bnep 24576 2
hci_uart 86016 1
btqca 16384 1 hci_uart
btbcm 16384 1 hci_uart
btintel 20480 1 hci_uart
bluetooth 454656 28 hci_uart,btintel,btqca,bnep,btbcm
openvfd 196608 1
dhd 1052672 0
8192cu 663552 0
amvdec_ports 86016 0
v4l2_common 16384 1 amvdec_ports
videobuf2_dma_contig 20480 1 amvdec_ports
videobuf2_memops 16384 1 videobuf2_dma_contig
v4l2_mem2mem 32768 1 amvdec_ports
videobuf2_v4l2 32768 2 amvdec_ports,v4l2_mem2mem
videobuf2_core 53248 3 amvdec_ports,v4l2_mem2mem,videobuf2_v4l2
sch_fq_codel 20480 8
ipv6 512000 38
wifi_dummy 16384 0
amlvideodri 24576 0
videobuf_res 16384 1 amlvideodri
videobuf_core 36864 2 amlvideodri,videobuf_res
videodev 294912 6 amlvideodri,v4l2_common,amvdec_ports,videobuf2_core,v4l2_mem2mem,videobuf2_v4l2
media 45056 1 videodev
fbcon 61440 0
bitblit 16384 1 fbcon
softcursor 16384 1 bitblit
font 20480 1 fbcon
CoreELEC:~ #

@cdu13a did you forget about me? :wink:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.