Smb shares timeout problem

Hope someone can help me with this because it’s annoying me that I can’t find the cause. I have three boxes ALL of which are running the 15/9 nightly.

  1. NG which has an external hard disc “TOSHIBA EXT”. This box also acts as a Plex Server using docker
  2. S905 which has the drive mounted to storage as /storage/TOSHIBA. This box can also see the drive as a smb share using either Windows network or zeroconf browsing.
  3. S905x which can see other SMB shares BUT not the TOSHIBA drive. Windows network, zeroconf and even an added smb share, all come up with the message “connection timed out”.

Can anyone point me in the direction of fixing box 3? I can say it is not:

  1. Version specific to box 3 cause I’ve tried other nighlies and 9.0.2 stable
  2. The mount on box 2 that’s stopping access because I still get no access when box 2 is turned off.
  3. The nightly on box 1 because box 2 can still see the smb shares.

Suggestions will be gratefully received

Just for the record, this was solved by unplugging and replugging the power line adapter serving box 3. I am so glad for my sanity but why it was allowing internet access and other SMB shares on the network, I’ll never know.