[SOLVED] A95X MAX S905X2 cannot boot CE

Having just ordered one, my fingers are crossed that there is a driver for the latest revision of WiFi/BT.

Received my box today and initial tests are good.

If it gets confirmed that there is no available driver for the MT7668RSN then I’ll order a CSR dongle to give me Bluetooth.

HDR to SDR tone mapping works for locally stored and streamed files but I did note that when playing a streamed 4K HDR file from Youtube that the mapping didn’t work.

Although I have things running well from a MicroSD card, I’m curious about the earlier posted file A95X_MAX.tar.gz and whether it has any practical use for the end user?

I’m guessing not if I have a working system but wanted to get absolute confirmation.

I did this to get the front panel clock working.

Install the openvfd addon (Coreelec nightly addons, services, openvfd)
Create a vfd.conf file as described here and copy it to /storage.config
Reboot and it works.

2 Likes

YouTube uses the VP9.2 codec, and HDR doesn’t work with VP9.2. Same goes for HDR to SDR tone mapping.

Thanks for the clarification.

In case others may be interested in the process, the following is how I achieved installing Coreelec to an SSD on the A95X Max, so that you can have dual boot with Android running from the internal eMMC. The best of both worlds, so to speak.

There will be more than one way of achieving the same goal with differing Operating Systems and tools, so you may well have an alternative/better method but this is one way.

This guide assumes that you will be using a Windows PC, that you have some familiarity with creating the necessary environment for using Coreelec (or even Libreelec if you are coming across from that). Generic instructions are available here should you require further reference on the basics.

You will also need to know how to boot from an external flash drive on your PC.

You will require (apart from the HDD/SSD and A95x Max):

  • Suitable external caddy/sata to usb cable to connect drive to PC.
  • Spare USB flash drive that you can afford to wipe to become a boot device.
  • Generic Burning Software (Rufus/Etcher etc). Rufus is used for this guide. Download here
  • Generic Partition Wizard Application (MiniTool Partition Wizard Free is used for this guide) Download here
  • Gparted ISO (Most likely amd64 version) Download here
  • Dummy.zip file (basically an empty zip),Download here
  • Latest Coreelec Nightly (NG Generic .img.gz build) Download here
  • vfd configuration file (To get the box fascia clock working when Coreelec is in use) Download here

Burn CE to your HDD/SSD just as you usually would when using a USB flash drive or MicroSD card. Rufus will likely not see the external drive at first, so check the box labelled List USB Hard Drives in order to make it visible.

Copy the relevant DTB file for your box model into the root of the Coreelec partition and rename to dtb.img

Copy the Dummy.zip file to the root of the Coreelec partition.

Run the Partition application, select the drive (the whole disk, not just one of the partitions), right click and choose the option Convert MBR disk to GPT Disk . Click the Apply button to carry out the conversion.

Eject the HDD/SSD and remove from your PC.

Burn the downloaded Gparted ISO file to a USB flash drive (again using Rufus) and then boot from it into Gparted (You may need to change BIOS/UEFI boot settings to enable boot from the flash drive). You will be asked to enter a 2 digit code for your chosen language and for how you would like Gparted to present itself, so choose 0 for the GUI.

Once Gparted is loaded, connect your HDD/SSD to your PC and select the menu bar option to update the drive list ( Gparted, Refresh Devices ).

You should be able to see your drive but if there is doubt about which one it is, from the menu bar select GParted, Devices, Select Disk and choose what you think is your drive. If correct you will see the partitions, including one labelled Coreelec .

Right click on the Coreelec Partition and choose Manage Flags and from the pop-up list, select Boot , then the close button when complete.

Close Gparted, choose Exit and take the option to Shutdown .

Remove your drive and install it into the A95X Max, where the first boot will be to Coreelec, taking a little longer than normal to complete and boot in order to set itself up. If your TV screen is off when booting, you may well find that the first boot does not invoke CEC, so you will have to turn it on manually.

Set-up Coreelec as desired.

To use the vfd file, Install the OpenVFD Service in the CoreELEC repository in Kodi and Copy the vfd.conf to /storage/.config, then reboot to apply. More info on configuring vfd files here.

Notes:

When using any partition tool, ensure that you do not modify the wrong disk otherwise you could end up wiping an important boot/data drive or partition(s).

Upon switching on the box, first boot will always be to Coreelec, so to get to Android, choose the option to reboot to internal.

V10 of the box board should enable use of WiFi and Bluetooth but later revisions marked V81 currently have no supporting driver, so compatible external USB dongles would be required should these services be required.

Android cannot see the SSD and Coreelec cannot see the internal eMMC, so local sharing of data would be achieved using storage connected to the USB ports and/or MicroSD card slot.

3 Likes

Hi all,

I’m just a coreelec newbie and I’m interested in installing procedure on A95X MAx (4gb + 64GB).

Some, probably stupid, questions.

Since a nightly build has been used, should I always refer to Latest Coreelec Nightly (NG Generic .img.gz build)?
There is some TRICK to boot from USB memory stick? vfd file should be loaded in the file system in a special position?

Thanks!

I knew that I would forget something lol

I’ve updated the guide with the vfd information.

As far as I know (but I could be wrong, there is no stable release for S905X2 yet), so nightly builds are used. You can update from one release to another using the relevant .tar file

I’ve not tried to boot CE on this box from a USB flash drive but I think that you have to use the USB 2.0 port on the rear and most likely have to use the toothpick in the AV port, holding it in and then plugging in the power, holding the button in for 10 seconds. Others may be able to clarify as I went straight for an internal SSD boot.

1 Like

THANK YOU!!!

I’ll try with the “toothpick way”. I’m not interested yet to start from SSD.

I hope to share good news here!

Back Again.

I’ve flashed image as described and followed the procedure, but , probably something went wrong.

I’ve discovered that the RESET button is inside (!!) the AV

Trying to follow the procedure my box stucks on A95X on the screen

Any suggestion?

REGARDS!

I’m not entirely sure what the issue would be here but first, take out the SSD/HDD and make sure that you can still boot to Android.

BTW there is an OTA update for Android that has come out in the last few days that is worth updating to first.

If All is well with Android, also download the [https://apkpure.com/reboot-to-libreelec/me.thomastv.rebootupdate](http://Reboot to Libreelec apk) and install it (it will come in handy when Android is updated as it will need to be run to get CE to boot).

Put the SSD/HDD back in and boot.

Hopefully, Android will boot and from there you can run the Reboot to Libreelec app that will enable boot to CE.

HI,

thank you for your reply.

Probably I’ve been unclear: I cannot boot from USB that , in my simple plan, was the first step.

Probably something was wrong with Image or with chosen USB PORT.

Can I use the app you’ve suggested to start from USB too?

Any additional suggestion?

Thank you!

Oh right, I see. I understand.

From what I know, you have to use the rear USB 2.0 port to boot and if that doesn’t work, write it to Micro SD card.

The app simply redirects to boot from an external source, which should include USB and Micro SD card, although the toothpick method should also work.

If you find yourself having no joy, I’ll remove my SSD, burn to USB and Micro SD card and try it for myself, although I think that if you read further up this thread you will likely see that boot from external USB etc has worked for others, so worth a read.

Hi compent, excuse me for the newbie question about vfd.conf: where is the /storage/.config folder? I have a A95XMax and inside the /storage folder there isn’t a directory called .config. Even inside the pendrive usb that I use to boot I don’t see that folder.
Thanks

All the folder with . in the first char in the name is hidden.
So keep looking for it.

Ok, thanks, I had already switch on “show hidden files” option in Root Explorer, I see other folders with the . in the first char but I can’t find .config anywhere.
Where is it supposed to be? In the tv box internal memory or in the usb flash drive that I use to boot CoreElec?

In Kodi Settings/Media/General -> enable “Show Add source buttons”.
Then in Kodi File manager -> select Add source -> Browse -> select “Home folder” -> OK
It will be named “storage”. Then in File manager you’ll see all folders in storage, among them the folder you need .config

Thank you very much!! It works!! :grin::grin:

For the owners of the A95X MAX: which cfg file do you use to get the remote working?
Thanks

I haven’t found any that works so I created one myself.
It’s not perfect but it works:

table T95M, type: NEC

0xdf1c KEY_POWER
0xdf47 KEY_LEFT
0xdf1a KEY_UP
0xdf07 KEY_RIGHT
0xdf48 KEY_DOWN
0xdf06 KEY_ENTER
0xdf0a KEY_BACK
0xdf42 KEY_HOME
0xdf18 KEY_MENU
0xdf03 KEY_PLAYPAUSE # mouse
0xdf54 KEY_1
0xdf16 KEY_2
0xdf15 KEY_3
0xdf50 KEY_4
0xdf12 KEY_5
0xdf11 KEY_6
0xdf4c KEY_7
0xdf0e KEY_8
0xdf0d KEY_9
0xdf0c KEY_0
0xdf41 KEY_EPG # Web (Mapped to EPG)
0xdf01 KEY_INFO # Media (Mapped to Info)
0xdf5c KEY_VOLUMEDOWN
0xdf5d KEY_VOLUMEUP
0xdf10 KEY_BACKSPACE

A95x (478 Bytes) rc_maps.cfg (800 Bytes)