[SOLVED] A95X MAX S905X2 cannot boot CE

This box is a 4GB/64GB version and it cannot boot CE.
Somebody in a Hungarian forum got the uart log and the dtb from the box and asked me to share it here:
This is normal boot, I asked him to catch the failed CE boot too.

aml log : R-2048 check pass! aml log : R2048 check pass! aml log : R2048 check pass! aml log : R2048 check pass!

The bootloader is locked

1 Like

If the bootloader is locked how come there is a ‘boot log’ showing it booting ‘linux 4.9.76’???

aml log : R-2048 check pass!
aml log : R2048 check pass!
aml log : R2048 check pass!
aml log : R2048 check pass!
ee_gate_off …

Booting Android Image at 0x01080000 …[/code]

original kernel and dtb are also encrypted and will be loaded after decryption of the RSA signature

@bumerc, but how they can start balbes images in that case?
Any workarounds?

Try reflashIMG_20190731_124850

I can only imagine that the custom kernel will be loaded in conjunction with original dtb in this case

CoreELEC (CoreELEC-Amlogic-ng.arm-9.1-nightly_20190731-Generic.img) boot attempt:

After this it went to recovery but even the recovery cannot worked.
Sd card removed, reboot, A95 logo on the screen and freeze.
On the UART log just scrambled characters.
Another attempt to go to recovery (without sd) was succes, wipe cache, wipe data made the box booting again.

I am not sure what “aml log: Sig check” means. The kernel & dtb get loaded normal and bootm gets executed. But then it fails about this message and continue to search another kernel. Maybe the kernel need a checksum? I have to take a look. But not before end next week. Was it ever booting CE from SD? There was the cfgload update a few days ago.

CE cannot boot on this device. Never ever.

Ok, thx! Then it’s not related to the new cfgload feature! :stuck_out_tongue_winking_eye:
I will take a look next week. I guess there is a “security” check of the Linux kernel what fails…

Could you please tell me how to build the CE image, debug it and retrieve the logs from the box? I have the A95X F2 and I’m a C++ software engineer. May be I can help if I could get the basics.

The box was flashed with atvX_v3A_A95XMAX.img
After that he tried to run armbian
Armbian _5.91_Aml-g12_Debian_buster_default_5.2.0-rc7_desktop_20190708.img works

CoreELEC still cannot boot:

CE did something on the emmc, because it needed to wipe data/cache to start android again.

He also tried LE:

Boot is OK
There is sound and video usb mouse works.

Any idea why only CE cannot start but anything else can?

Bad Linux ARM64 Image magic!

For ARM64 kernel images, try using the “booti” command instead of “bootm” in config.ini

First 4MB of mmcblk0 and 1, fw_printenv booting LE:

The box can boot CE with @Portisch’s modified cfgload (the second):
Removed by Portisch as it is already included in the nightly.

Does this mean we’re any closer to getting a CE build?
balbes150 is dissing you guys on the libreelec forum…quote ‘Coreelec are using an outdated and not compatible with other new systems technology’ :crazy_face:

Balbes is not a reliable information source…
With the second cfgload from the attached tar.gz you can boot CE on this box.

ok thanks, probably above my pay grade but I’ll have a ‘mess’…
which image do I need for s905x2? ‘normal’ or ‘ng’?

You need -ng.

just updated my old s905x box - wow that RED theme is a bit horny :heart_eyes::rofl: