[SOLVED] Abox A1 Plus S905x 2G

A family member asked if this box could use CE, having seen my Tanix running it.

I unsuccessfully tried several ways of booting it and the closest I got is the following:

CE 9.2.0 on SD card using glx_p212_2g.dtb
update.zip file on USB stick
Reboot to recovery
Apply update from EXT

Result: The following is produced at the bottom of the screen

Supported API: 3
-Install /udisk/update.zip
Finding update package
Opening update package
Verifying update package
E: footer is wrong
Update package verification took 0.1 secs (Result 1)
E: Signature verification failed
E: error: 21
Installation aborted

Maybe a different dtb.img would be better?
Some other cause for this?

Thanks for any help available.

You need to remove the USB stick and just hold the reset button on first boot.

There are no reset buttons that I can find on this device … no on/off, no pinhole and no other that I can see.
This was the main cause of me going the route of using both USB stick and SD card.

Is there some other means of invoking a ‘reset’ when booting?

The usual method is with empty update.zip file on uSD and rebooting from Android to update or if box is rooted then rebooting with “Reboot to Libreelec” app.

Thank you both for the help.

OK, using ‘Reboot to LE’ got a successful boot of CE on the SD card … being a new installation it resized partition successfully and rebooted.

Unfortunately I must have selected an incorrect DTB and it only got as far as displaying the version across the top before it rebooted and went into a loop.

Suggestions on which DTB to use would be welcome.

Would it make any difference if the ZIP was on SD or USB?
I can try it …

or if box is rooted then rebooting with “Reboot to Libreelec” app.

I will try this also … was afraid of some incompatibilites so have not done so yet.

I always do it with update.zip on uSD card, never tried it with USB combination, because all Android updates are done from an uSD card…

I used Reboot to LE successfully.
Tried a lot of DTB files.
I have not yet found a DTB file that will boot the SD card to Kodi … goes into a loop after showing the version number.


I used the 9.0.3 Amlogic.arm release ; dtb image gxl_p281_2g_a95xr2.dtb
It got to Kodi.
Wired and Wireless networks working.
LiveTV & Radio using tvheadend pvr client is working … both DVB-T and DVB-S

I might try the 9.2 release later in the week to see if that will upgrade from 9.0.3

For the present, this will do to demonstrate CE working on the device.

Thank you all.

If CE works on this box with 9.0.3 it will (most probably :slight_smile: work with 9.2 too.

I couldn’t leave it :smiley:

It updated to 9.2 without incident!

Strange that I failed (for some reason unknown to me) to get 9.2 working without going through 9.0.3 first … I must have been doing something weird :slight_smile:

Anyway … all good now, and another box tested and working in basic mode.

Thanks again.

Just to confirm that this thread saved my sanity, after trying and failing to install CE on a Viden M16 2GB box. Wasted a day trying all methods, imgs, via both usbs/sd. It just would not boot into CE. However just as I was on the verge of giving up - even though they were different boxes - I tried the CE 9.0.3 img with the gxl_p281_2g_a95xr2.dtb, instead of the glx_p212_2g.dtb. And bingo! Then it also updated to 9.2.1 no problem and it’s running brilliantly. So thanks for the heads-up.


I own an “abox a1 plus” and I just bumped into this thread and I’m looking to repeat same installation success you’ve got.

I understand I’ve first to install CoreELEC-Amlogic.arm-9.0.3-Generic.img.gz then upgrate to latest CoreELEC-Amlogic.arm-9.2.5-Generic.img.

The is an issue though… it seems I can’t find anywhere the gxl_p281_2g_a95xr2.dtb

Is there any link to download it ? Do you still have a copy of such file ?

Appreciated any help.


is for SOC S905W

What SOC is your box ?

These brand names mean nothing to me.
Is it not in the Device tree folder after you’ve burned image ?


not sure how similar the “abox a1 plus” vs “abox a1 max” are…

currently my a1 plus has 2GB RAM, 8GB ROM, amlogic quad core and it is running android 6.0 marshmallow (“s905x016-userdebug 6.0.1 MHC19J 20170821 test-keys.img”)

not sure if on the BE download I should just focus on a1 max or generic s905…



I just realized that the all the device tree (including gxl_p281_2g_a95xr2.dtb) are inside the CoreELEC-Amlogic.arm-XXX.img so plz disregard my former request.

I can start now the ugrade and I update back with any result outcome.



succesfully upgraded my abox-a1-plus to 9.2.5 using abox-a1-max template.
Both the wired and wireless interface are well recognized as well as the usb-keyboard.

The only drawback is that the IR remote does not work anymore.
I can turn the tvbox on with the IR but then to shut it down I’ve to rely on the usb-keyboard.
Is there any way to restore the IR remote as well ?

In the meanwhile I also managed to access via ssh
CoreELEC (official): 9.2.5 (Amlogic.arm)
CoreELEC:~ #
CoreELEC:~ #

Thank you so much,