[SOLVED] Aml-vnc addon

Hello, I am trying to get remote access working, can see the UI but no control - keyboard or mouse.

  • Coreelec 9.2.4.2 on Odroid C2
  • installed Amlogic-vnc add-on
  • access from Win 10 PC with VNCViewer

Is there any other service to be turned on or command? Thanks for any help.

You only need the Amlogic-VNC add-on. Maybe you mis-configured something in the add-on settings.
There is no mouse control, only keyboard control works.

Thanks for your input. I left the add-on settings on default - port 5900 and default authentication.
Are there other settings other than those on the add-on GUI? Something to be done on the PC side maybe…

@TheCoolest I just reinstalled the add-on and have keyboard controls! Thank you!

Hi, I am having similar issues with Amlogic VNC addon (the one that comes with latest stable 19.2 version). I can connect without issue, but no control, and the screen refreshes very slowly. Any changes to configuration I can make to improve on it? on the vnc viewer side?

1 Like

same for me…

Hello,

There is control, but it detects late, that is, there is delayed control.

Kind regards…

ok, i just resolve my issue (too much delay with keyboard and frame, more than 30s), we have to open 5900 port (do it safely, example to do it/)
now it’s clearly quicker than before, I set the lowest quality also, it is now usable to setup things remotely. Don’t expect to use this plugin to watch video, it won’t work (black screen)

-edit- weird, I had a correct fps (something like 1fps, enough for menu), now it’s like before, so not the solution finally :frowning:

Hi this addon suddenly stopped working for me. Get a blank black screen on my windows client when I connect to the box.

Have you tried reinstalling the addon?