[SOLVED] Any Ugoos AM6 users help with LAN speed testing

I have an AM6 PLUS box - it supposedly has Gigabit Ethernet per the specs

I have run IPERF3 tests in both Android and CoreELEC and it maxes out at 95Mbps - this is using the same connection where, with a Windows machine, I get 500Mbps across my LAN
And also - when connected to Internet (my service is over 500Mpbs), again I am limited to ~95 Mbps download speed with that (while it does over 200Mbps on 5G and actually gets 500Mbps to a relatively local server on Windows machine at this node)

There is another user on another forum reporting the same kind of numbers

I am starting to believe this is not at all a Gigabit device, but only Fast Ethernet (100Mbps)
I have contacted Ugoos and waiting to hear back from them

It would be interesting to have others with Ugoos AM6 run the iperf tests also and see what you get - can anyone actually validate they DO get Gigabit capability from the Ethernet port?

Are you sure using at minimum a CAT5e LAN cable?
I also had only a short CAT5 cable extension in my setup and I got only ~95MBit.
But I can tell you 100Mbit should be enough for almost every media playback.

Have had this same box for a week now and was waiting until someone else posted regarding the lan connection speeds. Am on the 0.3.3 dual boot CE firmware, in android am getting a full hit of just over 200mbits but in CE its just over 100. Out of interest I tried it yesterday with a vpn on and got around 174 and couldn’t get my head round this. Was using a gt king pro beforehand for a good few months with the same Lan cable getting the full hit in android and a slight drop to 180 in CE but with the ugoos rev b the drop is a lot more in CE.

How did you measure the speed?
Don’t use GUI speedtest addon in CE, it gives wrong values

Arnu box speedtester have used for a while now, same as with the gt king model. Just getting far better results with the latter. I thought the ugoos would outperform this model but am now regretting the purchase.

Use iperf to test local network speeds.

Yes, Cat 6 in the house (ran it myself) and cat 7 between the the router and the 2 reference points in question.Actually Eliminated the house component and now just have my Windows server & AM6 hooked directly to router in same room, both connected with 2m cat7 only
Besides - as stated am getting 500Mbps when other systems hooked to exact same nodes, so validates not a cable transmission issue
Also eliminated router and connected Ugoos directly to my cable modem - that is still capped at 95Mbps Download from a local Internet Test Server (where I normally get 5-600Mbps)

That’s not the point which is that I bought a box that has stated 1GB specs and it will only transfer files on my LAN at 100Mbps and also throttles the Internet connection on Ethernet by this same bottleneck

This is what was used although the Internet Download speeds are also throttled to the same maximum as obtained by local iperf transfer rates.

I tried it after your suggestion - VPN made no difference (and not sure why it should in your case?)

  • my Download speed is still capped at 95Mbps (this on Android Chrome Browser running a speed test)
    My Internet speed is not the fundamental issue - the issue is that the Ethernet Port will not allow faster than 100Mbps as validated by iperf and that consequently limits my Internet Connection speed also

You can run ethtool eth0 to get information about your connection status.
Did you check autostart.sh to make sure that you don’t have anything that forces the connection to 100Mbit/s?

Thank you
I haven’t used ethtool before but here we go
So here is the output
Is that the relevant part of this report that I’ve circled?

I haven’t yet looked at the autostart.sh - but that would have had to have been defined by the original firmware wouldn’t it? (and why would they?); also is the same whether Android or CE

This is how it looks on my N2

Your “Link partner advertised link modes” does not list (report) 1000baseT/Full mode, probably the limitation of the device your AM6 is connected to…

That would be the router - but why then do other devices connected at this exact same node (router port and cable to it) work at high speed?
Also as mentioned, even if I connect directly to my Modem I cannot get better than 100Mbps

Probably some compatibility issue. If you have any 1Gbit switch that connects to your router at 1Gbit speed, try connecting AM6 to it to see if then you’ll get max possible connection speed.

Btw, run “ethtool” when box is connected to your modem, to see the situation there…

I can’t disconnect the modem currently - Mrs is working from home and needs the connection, so limited to what I can do
I did however swap to a different port on the router (and use a different cable although really don’t think the cable was issue) and re-ran the Eth0 and here is also the iperf data

Here is the device at limiting your speed, since you have 1000 speed at disposal.

OK this is embarrassing :blush:

In the image in last post I realized I had my VPN on; disconnected that and the first part of the new image is the result (that is with the new local cable to the AM6 and the different port)
The second test is with the CAT7 cable attached
and the third test is with that Cat 7 swapped for the Cat6
eh Voila …
The same Cat 7 cable (pre-made purchased cable incidentally) showed good transmission with Windows, just doesn’t like this box for some reason

So now the transfer rates are good in both Android and CE at ~500 Mbps and the Internet Download is over 350 in Android (as mentioned don’t really trust the Kodi/Arnu speed test in CE)

So sorry for wasting everyone’s time - all of your inputs were extremely appreciated and especially the suggestion to run Ethtool which got me pointed in the right direction.

One more post script
I moved box back to its original HTPC location (which runs through the house interconnect CAT6 wiring) and back to the low transmission - well, of course that location has the exact same brand CAT7 cable between the wall port & the Box
(I purchased these cables together - only bought the CAT7 because I think they were on special sale on Amazon at the time)
Now what is bizarre is that both these cables work PERFECTLY with Windows systems and transmit full rate - it’s only on Android I see the problem (those same CAT 7 cables actually give the same problem on my Minix box - but again they are both perfect on my Intel NUC box running windows)

So what could possibly be different about how these cables interact with the Windows Adapter vs the Android one??

It could be also some connection issue between cable connector and box port or cable issue. 1 pin issue = not stable connection or speed dropping to 100Mbit

Maybe an incompatibility of CAT7 GG45 connector and RJ45 jack (up to CAT6).
CAT7 patchcables are not designed to be downward compatible with CAT6 devices, while CAT6 patchcables will work with CAT7 devices (up to 1G)