[solved] Audio with Passthrough worked well for TV, but not now


I have successfully setup the Odroin-N2 connected to my Denon X1000, which is then connected to Samsung TV. I set-up in audio settings to Allow passthrough, so the receiver play well all the supported formats like AC3, DD+ DTS, etc, once the receiver is on. Once the receiver was off, my TV played video and audio as well. I set up audio output device HDMI Multi Ch PCM with 2.0 channels.

Suddenly the audio is playing only when the receiver is on. With the receiver off I cannot hear it. Video is playing well in all the cases.

I was trying all the settings on Kodi/CoreELEC, also on receiver, but did not find the root cause of the issue, why the audio is not working when the receiver is off.

Any idea?

Thanks for your suggestions.

What device were you using before the N2?
Some platforms check device capabilities, and then “decide” what formats to use for audio.
CoreELEC always bitstreams the formats you select, if your TV can’t play them, or your AVR is not passing them through to the TV, you’ll hear nothing.

Thanks TheCoolest for your reply.

My issue is that it already worked in this set up (N2-AVR-TV). Audio and video worked fine with the AVR on and off. So the TV supports the audio formats. But now the audio and video is working fine only when AVR is on. When AVR is off only video is fine and I do not hear anything. So passthrough somehow work, but only for video.

Likely I changed any audio/video or CEC settings on any of these devices (N2, AVR, TV) which caused that the audio does not work.

Any advice where/on which settings shall I focus?

Take a look at your TV’s audio settings. It sounds to me that the receiver is selected as ouput source. At least for me with similar setup, I don’t get any sound with passthrough if the receiver is selected as TV’s audio output. If that doesn’t help, try to disable HDMI-CEC on your TV

I found the reason for that and TheCoolest was right. It is really that my 10 years old Samsung TV LE46C650 does not support DD+. I use N2 mainly as Netflix player, where the DD+ is default audio format. If I switch it to other formats, it works fine :slight_smile:.