[SOLVED] Black screen through AVR

Just bought two brand new ODROID N2 CoreELEC Edition boxen, as they promote the best out-of-the-box experience… Of course, all I get after I plug it into my AVR is the black screen. :frowning:

I’ve used Latte Panda, RPi 3 and 4 with this AVR and all of them worked fine. With N2 I see the bootloader image, but as soon as it starts booting the kernel, everything goes quiet.

I’ve tried adding these lines to config.ini but it didn’t seem to make a difference:

setenv display_autodetect "false"
setenv hdmimode "1080p60hz"

If I bypass the AVR and plug it straight into the monitor, everything works fine (minus the sound part :slightly_smiling_face: of course).

Sorry, I am total newb with this SBC. What else should I try?

I’m no expert, so just to get you started on something:
Is your TV and AVR 4K UHD?
AVRs often have 2 HDMI signal modes. Standard and Enhanced. Enhanced would be required for 4K, so if the Kodi gui is set to 3840x2160 this might be the issue.
Did you use the same HDMI cabel for the tests (N2 to AVR and N2 to TV)?

Some more details on your TV and AVR may be useful. Maybe some logs…that’s more something for the experts.

Without AVR go to Settings, CoreELEC and set the 422 and the 8 bit limit options, reboot your box and try it with the AVR.

@timfolk none of my equipment is 4K capable yet. (N2 is the first piece of the puzzle :slightly_smiling_face:). My old school receiver is Sony STR-KS360.

@Pelican thank you, I will try this tonight.

In the meantime:

  • I’ve discovered that setting resolution in config.ini seems to have no effect whatsoever.

  • Here is what I see in the logs when connected to the AVR:

[    0.000000@0] vout: get hdmimode: 1080p60hz
[    0.354810@0] vout: vout1: register server: cvbs_vout_server
[    0.354815@0] vout: vout2: register server: cvbs_vout2_server
[    0.354816@0] cvbs_out: register cvbs module vout2 server ok
[    0.488340@2] vout: vout1: register server: hdmitx_vout_server
[    0.488344@2] vout: vout2: register server: hdmitx_vout2_server
[    0.489274@2] vout: create vout attribute OK
[    0.489392@2] vout: vout_fops_create OK
[    0.489395@2] vout: vout1: register server: nulldisp_vout_server
[    0.489444@2] vout: init mode 1080p60hz set ok
[    0.489498@2] vout: aml_tvout_mode_monitor
[    0.489506@2] vout: aml_vout_probe OK
[    0.685593@2] vout: vout2: create vout2 attribute OK
[    0.685688@2] vout: vout2: vout2_fops_create OK
[    0.685691@2] vout: vout2: register server: nulldisp_vout2_server
[    0.685695@2] vout: vout2: init mode null set ok
[    0.685791@2] vout: vout2: clktree_init
[    0.685834@2] vout: vout2: aml_vout2_probe OK
[    5.662087@0] vout: vmode set to custombuilt    *** ??? ***
[    5.851624@2] vout: new mode custombuilt set ok *** ??? ***
[    9.420032@2] vout: aml_tvout_mode_work: monitor stop
[    9.847563@2] vout: vmode set to null
[    9.847689@2] vout: new mode null set ok
[    9.847750@2] vout: vmode set to custombuilt    *** ??? ***
[   10.039654@0] vout: new mode custombuilt set ok *** ??? ***

It switches to some sort of custombuilt mode?.. When I boot connected straight to the monitor it says 1080p60hz instead. Maybe this is somehow related?

Here is my complete log: dmesg (91.2 KB)

Ah OK. I hope you get it figured out.

1 Like

@Pelican I tried that, but it didn’t make any difference. Still black screen (no signal).

Is there anything else I can try?

ssh to your box and run dispinfo when no signal with AVR and make another run without AVR.
Copy the link you get from dispinfo here.

@Pelican thanks again. Here is the output (sorry, no links – system is offline).

Direct: dispinfo_good (8.0 KB)

Through AVR: dispinfo_bad (8.3 KB)

And here is online diff: https://www.diffchecker.com/SuvUUBDv

You should try a fresh install of nightly or stable. I don’t know what is that custom mode in your setup.

@Pelican Well, this is a fresh install of CoreELEC stable 9.2.1… I suppose it won’t hurt trying a nightly build.

What’s the proper way to force a resolution with CoreELEC? My earlier attempt at adding lines to config.ini seemed to have no effect whatsoever.

There is no video mode like this:
VIC: 130 custombuilt
That’s why I thought it is not a fresh install…
If you didn’t change anything then your Sony messing with you.
Through the AVR there are no disp_cap modes so the CE cannot switch to any resolution.
You can try to save the disp_cap you get without the AVR to your config folder:
cat /sys/class/amhdmitx/amhdmitx0/disp_cap > /storage/.kodi/userdata/disp_cap

@Pelican yeah, I didn’t change anything… Just in case, I am downloading fresh Stable and Nightly images and will try both tonight.

So, if I understand it correctly CE will look for the file /storage/.kodi/userdata/disp_cap and use it to override current display caps?

Is there some sort of wiki or documentation where I can find out more about these “secret” files?

My system is offline and I have very limited time to work on it when I get home. I would like to be prepared as much as possible when I get home tonight.

Well, that’s all that was needed:

cat /sys/class/amhdmitx/amhdmitx0/disp_cap > /storage/.kodi/userdata/disp_cap

Not sure why it couldn’t recognize my receiver, but I am now back in business, including both picture and 5.1 sound.

Thanks to everyone for your help and support :slight_smile: