[SOLVED] Bluetooth not working

as I wrote, the 2x update 9.2 doesn’t work :slight_smile:
have you found the problem?

Yes, and if you don’t test the nightly, we won’t know if the problem has been solved or not.

ok, I’ll try later, probably on Sunday

I tried with the latest nightly (CoreELEC-Amlogic-ng.arm-9.2-nightly_20190919-Generic.img.gz), and on my device (Mecool KM9 Pro, S905X2, 16GB/2GB), bluetooth is still not working.
It was working with this : CoreELEC-Amlogic-ng.arm-9.1-devel-1565360317.tar
Found here: https://mega.nz/#!hW5gHYZQ!la2lnraC2mFUCN0kAMHeSkVfxoJPCgN0AYnzAKZItMQ

I’m not sure if the team mirrors nightlies to Mega but I’ve never known it.

Always best to get them from the CE Site as you can never know whether anything from elsewhere has been modified.

I have discovered an issue with the latest NG build with my S905X2 with an external CSR 4.0 dongle, where on boot CE shows bluetooth to be disabled, despite it being turned on, so when I disable and re-enable it tells me that no bluetooth adapter can be found.

lsusb confirms that it cannot be seen and every reboot shows the same issue.

Then I discovered the udevadm command, which initially seemed to enable detection of the dongle (although no use when dealing with internal hardware afaik).

I only mention it as a note right now as I’ve got more work to do in investigation and production of logs for diagnosis but it is a strange one for sure.

Thanks for the update.
BTW, this link to Mega was issued by a CE member (TheCoolest):

Looks like a test build just for you to test and chance, so that makes sense.

We unified the 3.14 and 4.9 AP6*** support now, so everything that worked on 3.14 should work on 4.9.
That includes AP6236.

Meaning from now on, like in the next nightly? :slightly_smiling_face:

can i have link of nighty(k3pro?

It should, but the DTB must match as well.

@tash75 https://coreelec.org has a link.

its also not working:thinking:

Do older versions work or has it never worked for you?
Also post the output from this command:
udevadm info /sys/bus/sdio/devices/sdio* | paste

I have just tried 9.0.3 it works fine. With the command, i don’t know how to extract it,

Run the command over SSH (you can use PuTTY)
Then copy the URL it returns and post it.

/$ udevadm info /sys/bus/sdio/devices/sdio* | paste
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0 0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0 0 1179 0 0 0 0 0 0 --:–:-- 0:00:01 --:–:-- 0100 1197 100 18 100 1179 7 518 0:00:02 0:00:02 --:–:-- 525

Not sure what that is, but it’s the not URL I asked for.
The paste command returns a simple url, none of the output you posted.

what about this: http://ix.HTTP/1.1

nope, should look something like this:

CoreELEC-GTK:~ # udevadm info /sys/bus/sdio/devices/sdio* | paste

am using WinSCP. PuTTY, give me format for “host name”