[SOLVED] Brand new Beelink GT King cannot run Coreelec no matter what!

Just bought a brand new GTK. After performing all updates with 10.10.2019 been the latest I did the following:

  1. Downloaded CE 9.2 stable.
  2. Burned with latest Rufus
  3. Copied the GTK.dtb to SD card root folder
  4. Renamed it dtb.img
  5. Tried with reboot update through terminal app
  6. Tried through press and hold reset with a pin and plug AC power until CE logo appears.
  7. Repeated all steps with a brand new SD card class 10 (previous was a very old and slow 1 Gb)
  8. Repeated all steps with latest nightly build

The only thing that happens is that after Beelink logo goes away, I get stuck to dark screen. CE logo never appears no matter what.

Any ideas?

There are 2 dtb files for GTK, try both… May be you have revision a box

My S/N starts with B922HQKF but anyway. I ll give it a go

All of them are S922X that could be revision a or b.
GTK serial is only related to used memory…

try run from USB stick first with app reboot to libreelec or reboot update

Have the same problem and run only from USB and after first run from USB is starting without problem from memory card

Eventually it was revision A (crooks from Geekbuying sold it as 2.2GHz and sys info reports rev A and 1800 MHz!!!) Now that I started CE, I am trying to configure lan that will not receive DHCP address from router!!! Had to do it manually

Just power off box, unplug the power cable and plug the power cable again, after that Lan should work

maybe try different dtb file for king, yesterday with fresh CE box getting some strange ip address from switch like 169.254.112.XXX and just replaced dtb and works again finr

With what did you replace it?

Like @boot2k3 said there are 2 dtb files. On both my King run but on one only DHCP working, no idea why.

Well my little adventure went like this:

  1. Installed nightly and repository was inaccessible. No PVR addons. LAN set to manual ip
  2. Rolled back to 9.2 stable. Inverted colors, repository inaccessible LAN set to manual ip.
  3. Tried installation of 9.2 several times and several ways. Same result!
  4. Decided to try again nightly. VOILA! Colors back to normal, LAN got DHCP address, add-ons accessible!!! Everything works :slight_smile:

Just to underline what @boot2k3 said. There’s a bug that doesn’t allow ethernet to work properly when coming back from android (no/wrong IP). The solution is to remove power cable and attach it again. Just rebooting from menu isn’t enough.

1 Like

Now how about HDR?

If I go to Settings/System/CoreELEC and select Tone map SDR to HDR to auto, the unit outputs everything on HDR (that also means HDR pass-through is compatible with my 3 year old marantz SR-6011) but image quality on SDR content looks terrible like dynamic mode. Also the kodi interface is too bright causing fatigue.

If I switch it back to off, 4k-HDR content is not displayed correctly. I need to manually switch HDR from the TV set. Am I doing something wrong?

I don’t know what TV you have, but if it’s HDR capable, and has HDMI 2.0 support, you need to set SDR to HDR off.
HDR works automatically with HDR content. If it doesn’t, then something in your setup is not correct.
You need to make sure that HDMI 2.0 is enabled on both your AVR and on your TV.

I have a Sony A9F 2019 and it is HDR capable. I had already set HDR to SDR off.

I suggest setting both of those toggles to off.
And you need to make sure the the input on the TV and the AVR have the HDMI 2.0 (usually it’s called some variation of “deep color”) option enabled.

I use CoreElec 9.2.1 and I have the same problem of no IP or IP outside my LAN (I set a static IP).
I unplugged my GT King and hope it will solve that in futur.

This problem was solved some time ago, can you explain your situation a little better?

My device GT King Pro.Firmware nightly 20200210.
Wireless seems to be connected and working.The device does not go to the Internet after a long wait but the IP address appears to be obtained.
My device has USB TBS5520SE DVB-S / S2 / S2X - DVB-C / ATSC-C - DVB-T / ISDB-T tuner attached. Images freeze at intervals.CoreELEC 9.2.1 works more stable.