|SOLVED] - Cannot install extension from unknown source


I just realized that in CoreElec 9.2.1 the unknown source option in extension parameters has been took off even in expert mode.

So I am not able to install from zip file !

(using CoreElec with Beelink GT King)

Have you tried to just install it?

To install what ?
I tried to install zip file in CoreElec 9.2.1 and I get an error each time

Here in French with Kodi windows we can see “Source inconnues” (unknown sources) but in CoreElec this option have been took off. Why ?

Because in CoreELEC you can by default just install what you want.

OK so why I get error message when I want to install a zip file ? (I tried wtih many).
Are you sure this option is always ON by default in the last CoreElec version ?
Is there any possibility to check this parameter with ssh and where ?

What message do you receive?

in logs
Echec de l’installation à partir d’un fichier zip
L’installation de l’extension en fichier zip depuis l’emplacement smb//…[zip file name] a échoué pour cause de structure invalide

I tried from two share directory windows from MY NAS and from my PC throught windows LAN

Not a valid .zip file - wrong .zip
Not a CoreELEC error

Absolute nonsense, we removed the option entirely and all related code and there is no issue installing zips, it’s a problem with your zip/addon.

Ok thanks for your help,
It is Aeon_MQ_8_Multi-Mod.zip
I am going to ask on kodi forum