[SOLVED] EPG times incorrect

Hi all,

CE 9.0.1 and TvH on an S912 box (TX92)

We were recently on daylight saving and it ended on the weekend. The time is correct on the box but the EPG times are out by one hour. How can I correct this?



System/Settings/PVR & Live TV Settings/General Clear Data

Guide as well / Clear Data

Also make sure

Settings / Interface / Regional / Timezone country

is set correctly. Reboot after you set this.

That did the trick, thank you.

It did the trick for me too so I thought I’d bump this topic to help the other head scratchers out there. Google and the CoreELEC forum are great.

This is not a satisfactory solution since the TV data contains more than just the EPG data, it also contains custom pathways to picons. This is a time consuming process to setup so clearing the TV data should be an absolute last resort.
This is a common recurring problem so needs a robust solution.


If you are talking about the operation of tvheadend, I do not agree with you, I do not make any adjustments to PVR & Live TV, except ‘Use channels numbers from backend’ = ON, and everything works great, and tvheadend takes care of everything (picons, epg [ I use 7 internal grabbers from different countries and different times ], channel numbers, channel groups, …). I have no problem in Clear data of PVR & Live TV, in all my Kodi clients of tvheadend.

All my EPGs are with my local time, even at the time change with daylight changes.

TVheadend is notoriously bad at correctly setting up the correct picons. When it inevitably fails the only solution is to use the Kodi channel editor to manually allocate picon paths for each channel - the details of which are stored in your TV data file. Clearing TVdata loses those manual allocations.

However it seems that it is only necessary to clear the EPG data to resolve the offset issue.


I have several Kodi clients, what I am not going to do is customize each one of them, so I fix this inside tvheadend. For the problem of the picons you just have to rename them with the name which wants tvheadend, you only have to do it once. So that they are not lost, keep them in /storage/.config/picons, so they will be saved with backups. When I change something on the tvheadend server I am sure that I am updating all Kodi TV clients.

This is a desperately tedious process from within the TVheadend interface - much more challenging than from the channel editor.


EPG times have also been an issue for me on all my boxes.

The clearing data option never worked for me as the channel listings would not repopulate.

So I had to clear data and then disable/enable TVH Server to force the repopulation.

I also note that this issue only occurs during the summertime daylight savings period.

Once the clocks go back an hour as they did this morning, times are automatically correct after each boot.

It’s something that I just live with and only takes 30 seconds each time to fix, so no biggie for me.