[Solved] HDMI Signal lost When play 4k60fps movie

Hello everyone. I have a x96max+ tv box(s905x3,4G ram
64G rom) with android 9.0 and coreelec nightly on it,andriod on the emmc,and coreelec on the sandisk high speed tf card. But I got “no hdmi signal” when played a 4k@60fps video,which played well on the android.
By the way,I have another s905d tv box(coreelec 9.2 stable version) ,it plays the same video very well.
x96max+ dispinfo before play :http://ix.io/2dVI
x96max+ dispinfo after play:http://ix.io/2dVJ

Anybody know why? Thank you!

It could be a few things, but I would suggest you try the cable. In android it normally outputs at the GUI frame rate, In Kodi it will try to output at 60Hz which is a much higher bit rate and your cable may not be up to it. When you are playing it back in android press the info button on you TV and find out what mode your TV is @ when playing back under android.

thanks for the reply.I use this HDMI cable to connect my computer and TV,then playing same video(4k@60fps,via potplayer) ,everyting worked ok.
When I use this HDMI cable to connect my tv box and tv ,and try to play the 4k@60fps video via KODI,the signal lost… ,so I think the cable may be ok.

Not necessarily. The video signal has another properties like bit deph and chroma upsampling which could be different. CE tries to send the best signal which needs bigger bandwith which maybe not supported by your cable.
You can try to limit the signal to 8 bit and 4:2:2 in CE settings.
Also you should set up your tv if it capable to show of HDR video.

Maybe, maybe not.
I don´t believe it´s CE related, cold be cable, TV settings or something like this.

All my boxes(S905X, S912, N2) running CE and play 4kHDR videos using good cables.
Crosscheck:
I tested the cheap cable which was delivered with 905X box - no 4k HDR video

thanks for the reply.
My tv does not support HDR, and I have also changed those settings that you have mentioned.
The resolution of kodi gui can not be set to 2160p@60hz

Did you reboot after changing these settings before changing to 2160p@60hz?

yes,I rebooted. I just turn VESA on (setting - coreelec - hardware - display),and turn off the 4:2:2 setting,and reboot the box,then I found the resoution of kodi CAN BE set to 2160p@60hz,but the hdmi signal still lost when playing ANY videos…then I think I should turn on the 4:2:2 setting ,after rebooted the box,I got a “no signal” screen after the coreelec boot screen.
What does the VESA used for?Is it the key-point?
Sorry about my poor english.

now I use this command to revert my screen to normal.
“echo 1080p60hz > /sys/class/display/mode”

Have a look at https://vesa.org/

@adamg @Tim_Taylor VESA setting works!!! Now I can play 4k@60fps videos.
kodi gui :1080p@60hz(or 2160p@60hz)
VESA mode -> on
8bit -> on
4:2:2 ->off
hdr to sdr ->off
sdr to hdr ->off

I never enabled VESA, my TV is working with VESA disabled.
Don´t know why You have to enable VESA mode

I think this is a new feature of coreelec-ng ,I have never seen this setting in prior version for S905D

I´m using the N2 as my daily driver with VESA disabled.
You said Your TV doesn´t support HDR, mybe this is the reason why You have to enable VESA

yes,I agree with you.Thank you for providing so many messages. :laughing: