[SOLVED] How to install on a Venz V10 device?

I’m a complete newbie!
I have a Venz V10 Android box but it’s really starting to act out (slow, freeze, etc…) and discovered that CoreELEC might be a better option than LibreELEC for running Kodi.

Apparently my device is compatible as it shows up in that list when I downloaded the CoreELEC installation file.

And I’m now having trouble installing it!
I tried pretty much every option available and relevant to my device found on THIS installation help page:

  • Khadas VIM & MINIX U1 / U9 are not for my device
  • Terminal Emulator tried that but got errors on reboot. The message that appears at the bottom of the screen is:

Supported API: 3
Recovery is listening adb sideload…
Waiting adb sideload command…
E: Cannot load volume /misc!

– No package file found selected.
E: Cannot load volume /misc!

And at the top of the screen, the option available to me are:

Reboot system now
Reboot to booloader
Apply update from EXT
Apply update from cache
Apply update from ADB
Wipe data / factory reset
Wipe cache partition
Mount / system
View recovery logs
Power off

If I remember correctly, I tried option 2-4 to no avail.

  • Toothpick method I have no reset button on my device (I do have a reset ‘button’ in the software but…this obviously can’t apply here since the device has to be off!)

  • Recovery method Not sure what to do here? What does that mean: “boot into Android” and how would I do that? My device is currently running Android so I can’t imagine it just means to turn on my device with the USB stick connected? Because if it does, it’s not giving me the “Reboot to recovery” option.

  • Recovery method 2nd variant Didn’t work. As instructed - and I must say it sounded odd? - I put a random .zip file on the USB stick and selected it but of course, on reboot it gave me an error when trying to process that .zip file?? (it was a zipped photo, but from what the instructions said, that shouldn’t have mattered, right?)

  • Recovery method (3rd variant). This is where I decided to post here because the instructions say rather unhelpfully "enable ADB (Google it)… ".
    I googled it and there are a multitude of different instructions on how to do this with various softwares to install so I prefer to get some advice from this community on how to go about it!

THANKS! :slightly_smiling_face:

Mentioned zip file should be empty (0 bites) and named update.zip

No it doesn’t, but thanks for the tip! I’ll try it now…(maybe it would be a good idea to mention as clearly as you’ve just stated it?)
As it’s currently written:

Recovery method (2nd variant) : If you have the Update app pre-installed in Android, open it, insert the CoreELEC prepared SD / USB and choose any ZIP file displayed in the app as an update. Your device should reboot into CoreELEC.

OK, maybe it doesn’t, but that’s how it works for me.
If your box is rooted install “Reboot to Libreelec” app which should also work…

The Venz V10 has a reset hole for the toothpick underneath the ethernet port. Be careful cause it is fragile and I broke it off by pressing the toothpick too hard. Sorry for not replying to your earlier post elsewhere. If you’ve set up your install on the SD card using the Venz version as a download, you don’t need to mess with editing the dtb.

You put a toothpick in the hole and press carefully until you feel a click.

Unfortunately nothing works! I’ve really tried everything (other than ADB).

Hey sonofdibnah! So glad to hear from you! You’re my only hope since I haven’t found a single other Venz V10 users on the forum! :smiley:

I had since found the reset button and tried that as well…didn’t work! :unamused:

I don’t quite understand what you’re saying here?:

If you’ve set up your install on the SD card using the Venz version as a download, you don’t need to mess with editing the dtb.

I’m currently using a USB stick but I’ll do whatever it takes to make it work so if a SD card is preferable or at least worked for you, I’ll do that but…what do you mean by “…the Venz version…”? There is no CoreELEC Venz version available, only a LibreELEC and that, yes I see it works but how do I get the CoreELEC install to work instead?
Are you saying I should first install Venz’s LibreELEC and then the CoreELEC? Sorry, I’m confused.

One interesting clue that might indicate a problem is, when I get to the boot/Android Recovery screen, I see at the very top Amlogic/p211/p211 while the dtb file I’m asked to install from the CoreELEC website is named gxl_p212_1g and not p211…could that be the problem? That it’s pointing to the wrong dtb file for my device?

I should also point out that Venz has two versions of the V10, identifiable by the serial number either starting with V10 (older) or V10B which is what I have.
Thanks in advance!

You should try with uSD card, because that is the method most Amlogic boxes expect to install updates/upgrades.
And try all dtb.img files because many times the one that “should” work dosen’t :wink:

Chumbo, I think I have the V10B too. my s/n number starts with V10B which I think is how to tell.

Go here https://coreelec.org/#download

Select the stable version. Select new installation. Then in select device you can scroll down to the V10 and the correct dtb will be suggested.

Then, using etcher or rufus burn the .img file to a sd card. (It isn’t just a matter of putting bthe .img file onto the sd card, you have to use an image burner such as etcher} You are going to run Coreelec off this sd card so it needs to be fast and I’d say at least 16gb. They are cheap and I’d suggest sandisc ultra. That said you can prove the concept with any sd card.

Once the sd card is done, rename the appropriate dtb as described elsewhere, pop it in the sd card slot on the V10 and power it up with the reset button pressed with a toothpick.

I take it that youy’ve read this How to install CoreELEC

This is incorrect. The dtb shown in the download helper is informative. It shows which dtb to choose and rename, as always has been. The only device that doesn’t need the renaming process is the odroid N2.
(The original post has been edited).

Thanks for pointing my mistake out. I really thought that the correct dtb was placed there but, in my defense, I did my install several months ago.

Please edit your post, better to remove the misleading part.

Ive edited my post and hope it goes some way to helping chumbo get CoreELEC up and running.

1 Like

Thanks sonofdibnah and the others!
That finally worked :smiley:

So for future reference for Venz V10 users, the trick is to in fact do the install from an microSD card using the Toothpick method. For the rest, it’s as described on the CoreELEC help page I referenced to in my original post.

However, now that I’ve got it working I have more general questions about CoreELEC but I guess those are best addressed in their corresponding forum categories so…maybe see you in another section of the forum! :wink:

Pleased your up and running. You won’t be disappointed I can assure you.

Hi sonofdibnah,

have you managed to run coreelec NG(kernel 4.9) on Venz V10 (Non pro?)
I got boot loop (after Coreelec logo) with ng version and gxl_p212_1g.dtb.

Standard (non NG) coreelec version wokrs ok.
I have V10B version of Venz V10 as you have.

Thanks for any hint.

Sorry @marek, I can’t help you. I broke off the reset button from the board many moons ago because of being heavy handed with the match I was using to reset. As you know, you need to do a reset to run the Ng version.