[SOLVED] Looking for working combination of USB/SATA Adapter with SSD >=1TB due to 'USB bus resets'

Hi all,
USB to SATA Adapter at the N2 is a hassle, that is a well documented problem.
Does anybody have a working combination of such and could share his findings ?

I have the famous USB Bus resets:
…] usb 1-3.1: reset high-speed USB device number 19 using …

My combination is an AMLOGIC ASM105x USB/SATA converter attached to a SSD ‘SAMSUNG EVO 870 2TB’.
Interesting fact, it worked flawless with a smaller capacity of the same series SSD 'SAMSUNG EVO 870 500GB’.

Attaching power supply to the converter did not help.

There are some threads in the ODROID forum that address the problem. Some state that AMLOGIC ASM105x USB/SATA bridge do work, but I must state the opposite.
BTW, the problem is independend of Kernel version or distribution. Appeared with ‘DietPi’, ‘ARMBIAN’ and ‘Coreelec’
Thanks for any comments !

Gerry

Sorry, I never heard of what you’re saying. Right from the start, two and a half years ago, I used SSD drives with a generic USB to SATA adapter box and never had a problem with amlogic S912 and S905X3 processors. The hard drives were 120 GB Kingston the first, and 1 TB of Chinese brand the second. The structure of these disks was typical of CoreELEC, a bootable FAT partition and an EXT4 storage partition (the 1 TB disk had a third EXT4 storage pool partition).

I am currently using 2 different CE and several Ubuntu operating systems on my SSD.
Petitboot causes problems with some OSes but CE works very well.

If you are having trouble booting, try with a USB2 cable, and all OSes will Boot smoothly. I found this solution by chance, my ssd cable was malfunctioning and I tried it with USB2 cable all non-booting OS worked.
The disadvantage of the USB2 connection is that the data transfer rate is very low.

Yes, I experienced this too with my N2. Both with external USB HDD’s and USB Tuner. Contacted Hardkernel and they sent me another N2, problem did not go away. Installed a NAS and HDHomeRun and problem fixed. Yes, expensive but now it never misses a beat.

SOLVED: Changing to another SATA/USB converter did help.
Now using " Sabrent" USB 3.0 zu SSD controller.
Tested various chipsets and this now works steady perfect since one week.

Other converters using the same chipset did not work or had significant drops in performance.

Thx all,
Gerry

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice