[SOLVED] Mecool M8S PRO L boot loop

Hi all,

I downloaded the 9.2.0 image for a fresh install on my Mecool M8S PRO L box but it is stuck in a boot loop at the coreELEC splash screen. I downloaded the image a second time to rule out a corrupt file with the same result. I used the dtb that the download helper suggested.

The 9.0.3 image works just fine using the same dtb so I’m guessing it is another issue? Has anyone experienced this or can suggest something to try?


This was a fresh install, not an update, so no addons would be causing the issue.

Was able to get 9.2.0 working by using the update tar rather than trying to do a fresh install.

Hey @NateBizzle how did you manage to reboot your TV box?
Also: did you make any different/additional change to the installation procedure of your fresh 9.0.3 version?

I am struggling to get CoreELEC booting on mine and wondering if there is any suggestion from your experience, thanks!

I have same problem with Z96MAX (s912/3/32gb) and H96 Pro+ S912/3/32/gb)
DTB is OK, previous versions are working.
9.2 is not booting. stuck on boot image.

I tried :
CoreELEC-Amlogic-ng.arm-9.2.0-Generic.img and

The -ng builds are for the new SoCs, not for S912.
Try again with the correct image and don’t forget to copy and rename the correct dtb.

You are trying wrong images. For S912 boxes use images without -ng in name, like:
CoreELEC-Amlogic.arm-9.2.0-Generic.img and

My mistake.
It is OK now. :+1:

By which method did you do that? I am getting the same splash loop, and nothing I try works. Thanks

I flashed 9.0.3 again since that boots fine, then followed the update instructions found here - How to install CoreELEC

I had to reflash 9.0.3 which boots fine, then I followed the update instructions found here to update 9.0.3 to 9.2.0.

1 Like

Mine ended up working with the menu button method.