[solved] Meson IR not working on ng-build

hi, now I tried some things and it still doesn’t work so I’ll ask you:

meson ir is working for me in the old kernel builds but not in the ng-build (9.2.5). I wrote back the backup from the old build and confirmed that the rc_maps cfg and corresponding keymap were still there.

ir-keytable -t (after stopping kodi and eventlircd) sees nothing.

amremote (remote.conf) works but sadly then kodi doesn’t respect my mapping in keyboard.xml (I don’t know why and I might investigate this further but now I’m mostly interested in getting meson ir back to work.)

I see some differences in dmesg that seem relevant:

old kernel, working (http://ix.io/2GDC):

[ 17.262435@2] Registered IR keymap rc-empty
[ 17.262944@2] input: meson-ir as /devices/c8100580.meson-ir/rc/rc0/input5
[ 17.263245@2] rc0: meson-ir as /devices/c8100580.meson-ir/rc/rc0
[ 17.274867@2] meson-ir c8100580.meson-ir: receiver initialized
[ 17.282175@3] IR RC5(x) protocol handler initialized
[ 17.282452@1] IR Sony protocol handler initialized
[ 17.288645@2] IR SANYO protocol handler initialized
[ 17.289294@2] IR JVC protocol handler initialized
[ 17.293180@0] IR RC6 protocol handler initialized
[ 17.297661@2] lirc_dev: IR Remote Control driver registered, major 229
[ 17.298962@0] input: MCE IR Keyboard/Mouse (meson-ir) as /devices/virtual/input/input6
[ 17.303783@2] IR MCE Keyboard/mouse protocol handler initialized
[ 17.304243@2] IR NEC protocol handler initialized
[ 17.307228@2] rc rc0: lirc_dev: driver ir-lirc-codec (meson-ir) registered at minor = 0
[ 17.307242@2] IR LIRC bridge handler initialized

new kernel, not working (http://ix.io/2GDp):

[ 10.751389@0] Registered IR keymap rc-empty
[ 10.751747@0] input: meson-ir as /devices/platform/c8100580.meson-ir/rc/rc0/input6
[ 10.753109@3] rc rc0: meson-ir as /devices/platform/c8100580.meson-ir/rc/rc0
[ 10.757605@0] meson-ir c8100580.meson-ir: AO_RTI_PIN_MUX : 0x109801
[ 10.757619@0] meson-ir c8100580.meson-ir: receiver initialized
[ 10.769099@2] lirc_dev: IR Remote Control driver registered, major 499
[ 10.772521@2] rc rc0: lirc_dev: driver ir-lirc-codec (meson-ir) registered at minor = 0
[ 10.772531@2] IR LIRC bridge handler initialized

this is a Nexbox A95x (S905x), using the rc keymap from the repo.

anyone have any ideas?

What repo? The one from the Repository for AmRemote & Meson_IR Remote Controllers?

Because that one works just fine on my NexBox A95X-B7N (S90X) (CE-ng device), which uses the same remote as the NexBox A95X-A95 (S905) (non-ng device).

yeah, your repo. thanks for that, btw!

it also works just fine for me in the non-ng build on the same box.
I don’t think the problem is with the keymap, I think it’s more fundamental, as even ir-keytable -t can’t see anything. but then again, what do I know…

would further logs help? I didn’t find anything related to the remote in the kodi (debug) logs but did in dmesg, so that’s what I posted. from the snippets above it seems as if the ng-build fails to “initialize the protocol handlers”.
but why or whether that’s even the problem, I don’t know and there I’m just out of my depth.

Did you use a raw copy?

Maybe try the amlogic version instead (remote.conf to be placed in /storage./config/)

I don’t know what you mean by raw copy, I used the file that I also used in the non-ng build and that I took originally from the repo.

amremote (remote.conf) works, as stated in OP, but I cannot map buttons (keyboard.xml) with that (don’t ask me why…).

Anyway, Meson IR should work as it does for you on the same hardware (A95x-B7N) and I’d really like to find out why it doesn’t.

I think right now I’m using the AmRemote version on the NexBox. Let me check and if yes, I’ll download and install the MesonIR version from the repo, this just to exclude a corrupted archive.

1 Like

The meson-ir keymap does need in the first line the protocol like this example:

The old kernel does use default NEC, the new one does not accept it when I am correct.

1 Like

ok, thank you, now I remember that the file does not have this first line. will try tomorrow.
do you happen to know what has to go in this line?

“# table a95x, type: NEC”

(file in rc_keymaps is named a95x)?

File restored from backup. Please try again. It should work now.

NexBox A95X.zip

1 Like

ok, it really was that first line that ng-builds need and the old kernel doesn’t.

thank you very much, Betatester, for providing the new file. I didn’t test it, just copied the first line to the old file and it works now.

have a nice Sunday!

NP, sometimes files become corrupted.
Thanks for letting me know. The problem should be permanently fixed.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.