(SOLVED) Missing Text using Aeon Nox SiLVO Skin


#1

Running:

  • Ott TV Box, X92, 3G, 16G
  • CoreELEC-S912.arm-8.95.7-S912.img.gz (and tried CoreELEC-S912.arm-9.0-nightly_20190124-S912.img.gz)
  • DTB: gxm_q200_3g
  • skin.aeon.nox.silvo-6.1.7 (Leia).zip

Everything so far looks wonderful except every skin screen is missing some text usually. Immediately after switching to/from Estuary, all SiLVO text is present, but after a reboot, some text is missing (it always the same text, not random.

Below are samples (left is OK, right is after reboot) and the system info screns. Any advice?





#2

It doesn’t seem to be a CoreELEC problem and you should talk to the author of this skin about this problem.


#3

On first image “Recently added” is missing: I assume this is because nothing was added after reboot? And you can enable all menus under “Main menu” and then “Submenu always visible”. No idea for other missing texts. Maybe corrupted SD card if run from there.


#4

Some updates and replies:

  • I installed the CoreElec/Skin software (different DTB, of course) on a T95Z-PLUS, and everything seems to work fine. This suggests to me there is some low-level issue with the X92.
  • re: relkai. The skin works on a different TV box, and so that favors not-a-skin problem. I did post a similar question there first w/o response yet, and I assume they are baffled. Nobody else posted any similar problem with the skin. I used several pre-Leia versions with success.
  • re: vpeter: On the first image, there are several missing texts, “Live TV” (menu bar) and “Recently Added” (Submenu bar). Both items should be present (btw, “Submenu always visible” is selected). I think there is a similar root cause for absent text on all the screens. Also, I’m now running on internal memory.

Thanks for the responses even if no help yet. I’ll re-install the skin again and try some other Hail Mary’s. I’ll avoid using the X92 for the meanwhile but re-try if given new advice and/or updated software.

BTW, CoreElec is great and I appreciate the effort in making it so. Thanks!


#5

I also use Aeon Nox SiLVO skin (heavily modified on top of that) on all my Kodi systems.
Your case looks like corrupted language file(s).
Re-install (from scratch) of the skin with complete cleanup of the “addons” and “addon_data” folders per the skin seems reasonable.


#6

In addition to the last answer check advancedsettings.xml to confirm that you don’t have activated smart redraw option.
If you see this string in this file <smartredraw>true</smartredraw> than delete it and reboot


#7

Problem solved by a complete reset of the system (including user data), and re-installing.

  • I assume ChimeyJimmey’s suggestion was the solution and there was a somehow corrupted language file. I implement this suggestion to the nth degree.
  • re boot2k3: I checked ‘smartdraw’ before the complete reset and that was not the problem.

Thanks for the suggestions … problem solved.


#8

My euphoria on having this fixed was premature. The problem resurfaced when I added a second profile. The problems occurs on every version of CoreElec (including latest stable and several contemporary nightly builds). The problem occurs on every type of device I have (i.e., X92, T95Z Plus, and A95X). It has nothing to do with persistent data corruption (almost certainly, IMHO).

Here is the minimal set of steps to reproduce:

  • Hard reset
  • Disable CEC Adapter and Mouse support (optional simplification)
  • Install SiLVO skin and switch to it; configure nothing except “Submenu Always Visible”
  • Add a second profile, log off and log into the new profile.
  • Disable CEC Adapter and Mouse support.
  • Enable SiLVO skin and switch to it; configure nothing except “Submenu Always Visible”
  • Reboot and log in … some menu text is always missing and always the same.

Now, to recover the missing text, simply log off and log in (switching skins does the trick but more effort).

Perhaps, boot corrupts the state or sets an unexpected state for the SiLVO skin (perhaps the language files?), but the state is corrected when switching skins?. Perhaps the skin is setting state properly on departure but failing to set the state on entry.

I’m unsure how to further isolate the problem. Any advice?


#9

IMHO,
this is not related to CE, as I’ve seen this on different platforms (Win/Lin/Andro).
I’ve noticed that this issue exhibits mostly when another input language/keyboard layout is added/changed.
I would seek advisement here, as this is skin specific, for sure.


#10

OK … thanks … re-marked SOLVED. FYI, a reply from the skin forum says a KODI problem per:

https://forum.kodi.tv/showthread.php?tid=332515
https://forum.kodi.tv/showthread.php?tid=333237
https://forum.kodi.tv/showthread.php?tid=333227
https://forum.kodi.tv/showthread.php?tid=333345


#11

Worth checking again, as Aeon Nox SiLVO Skin was updated yesterday :wink: