[Solved] N2: no signal on S/PDIF output

Hi!

I’m trying to use the S/PDIF output (from J7 connector), but I don’t get anything. Even when I select this output, the sound still goes to HDMI output!

Could it be something wrong with the device tree? I’m using CoreElec 9.2.7…

Thanks for your help.

Frédéric

I tried with another N2 board, and I have the same behaviour. This is not a fried output issue…

In fact, even if I choose the analog output, (which works), the sound also comes from the HDMI output!!! There is definitely something wrong…

Any idea what’s going on?

Just upgraded to 19.1, same issue :frowning:

And what do you have connected to this S/PDIF pin on J7 connector?

An AV receiver, which works fine with another S/PDIF output (from a cheap USB sound card)…

Sure AV receiver: but how do you have it connected electrically? Are you using optical transmitter with DIY circuit?

As J7 pinheader isn’t assembled on N2, HK DTB (and same for CE) muxed the SPDIF-OUT to GPIOA.13, available on J2 pin7.
This change was most likely done to support their Hifi-Shield extension boards.
I suggest to check/change your HW setup accordingly.

@vpeter, The J7 pin 2 is directly connected to the S/PDIF AV receiver input. Is it ok ?

@rho-bot, I’ll try to use J2 pin 7… I thought they where the same, but it looks like it’s not.

@rho-bot, it works!!! Thanks for the solution :slight_smile:

The SPDIF signal is still a CPU-pin, which is unable to drive a 75Ohms coax line directly. So you need a driver stage between cpu pin & Coax output. Without, this overstress may damage the CPU.

The SPDIF Output on Odroid is for usage with Optical SPDIF (TOSLINK) Transceiver, e.g.
https://forum.odroid.com/viewtopic.php?f=139&t=21477

I though you already used J2/pin7 - need to read careful next time.

Btw: I’m also using optical transmitter like on the link above on Khadas VIM3 device.

@vpeter, J7 pin 2 vs J2 pin 7… confusing! :wink:

@rho-bot, I will add an toslink connector as soon as I can find one from an old device… But it works fine without it.

1 Like

Then you are a lucky guy… Looks like your AV input is non-standard, missing the 75R termination resistor. Otherwise this would have caused EOS, as the max. current of the S922 portpin is specced at 6mA.

May I ask which AV you are using?

It’s an old Pioneer VSX-920. A North America model, that I’m using with a transformer (I live in France).

Checked the schematic of your AV, it has 75R termination:
grafik
The current drawn out of N2 pin is 7mA avg. with peaks up to 18mA. The max. specified pincurrent is 6mA. So you are operating out of spec.
Even if it works for you (up to now), I highly recommend not to use this setup, to avoid damage to your N2.

1 Like

Ok, thanks for the advice. I just soldered a toslink connector, but it does not work :frowning: I may have destroyed it while unsoldered it…
Any idea where I can buy a brand new toslink connector?

You don’t see red light coming from it? Did you correctly connected all 3 pins?

Nope, no red light! And yes, I connected the pins as they where on the board I salvaged it from.

@rho-bot, BTW, how could I limit the output current to use the coax input? The AV is maybe sensitive enough to still work…

There is no proper way, other than either using a line driver, or changing to óptical IF.

Any picture of your current connection?
What’s the marking of the Transmitter you are using? Could be it’s a 5V device connected to 3V3, or the opposite, which may have fried the Transmitter…

About | FAQ | Terms of Service | Privacy Policy | Legal Notice