[Solved] oDroid N2 and TV poweron and shutdown

Hello. I have recently bought an oDroid N2 (4GB) that I hooked up to a Sony Android TV (XF900 or X900F, depending on the market). I am very, very pleased with the overall usage and the integration with the TV (I can control it with the TV remote after powering it up). I have 2 small issues that I do not know if they are related to N2, the TV or to the 9.2.1 release.

The first one is that the TV switches to N2 automatically after powering on the TV. I noticed that recently, my N2 had 9.2.0 before, but I installed 9.2.1 a few days after receiving it. It is not a big issue, I can switch to the TV with a single button/
The second one is a little more severe. While watching TV, whenever I am shutting down my TV, it comes back on to the same TV channel I was watching (it takes a few seconds, I realized that I was able to hear the TV after shutting it down). It did not happen before connecting N2 to it, so I suspect that N2 with CoreElec has a part in it.

Is there anything I can configure in CoreElec or via ssh? I do not want to disable HDMI CEC, as using the TV remote to control N2 is extremely useful, not to mention that N2 is always on while TV is on. Any kind of help is very appreciated.

Settings / System Input / Pripherals/ CEC Adapter
Set the parametres there for CEC behaviour


Did not know there is something there. I will check it as soon as I get home. I knew I could do something. CoreElec is still new to me :smiley:

CE is only the operating system, You have to find out some configurations inside KODI

I never had a device with CEC before. This is why I am asking. I went into configuration of the HDMI CEC plugin and all my issues are solved :smiley: You can now lock this topic, thank you so much for the quick and very helpful replies.

Thanks for that tip kostaman…kodi(xbmc) user for years and never used cec as have harmony remote setup…forgot to check that setting in kodi when CoreElec N2 kept changing input while our PM gives the daily Covid updates! ( i would normaly of put lol here but under the current circumstances…maybe not)
sorted my issue after moving to CoreElec on N2 from a NUC6i5 - cheers!