[SOLVED] Odroid N2 Matrix 19_rc2 Black screen but sound on any 4k Contents

Hi to all,
i’ve a problem since a few day i can’t watch my 4k contents
when i try to play 1080p contents everything is ok with Kodi player or Plex

but when i try to play 4K contents in Plex or Kodi i’ve the sound only and a black screen
i can stop and restart the video, but the screen always remain black
neither the osd menu or anything is showed
i can’t even go back to the main osd menu of Kodi or Plex
unfortunatly i’ve to switch OFF the N2 to reboot the whole thing

i’m totally confused because that worked before and i’ve even try to switch back to MAtrix_19_Rc1 who worked before too .

i’ve a Panasonic TX-GZ1500 and i’m behind a DENON AVRX 3300

if someone have any clue to solve my problem

thanks in advance.

Try to connect the N2 to the TV directly and see if that helps.
Besides that, check the HDMI cables, bad cables can lead to problems getting a signal.
Also, make sure that the HDMI 2.0/UHD Deep Color option is enabled on the AVR and TV.

thanks a lot :wink:
i’ve done what you asked me to do and everything is working again

don’t understand why something who worked before doesn’t work anymore !!
sometime strange things happen

one day i’ll try to figure it out but for now i just want to enjoy my 4k contents

thanks again :wink:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice