[SOLVED] Self-compile builds no longer booting

@relkai (because you may know the answer very quickly :slightly_smiling_face:)

I have been using my own builds for a while now, but have not done any since v9.0.2. I re-cloned the CoreELEC repo, made my change (just a single kodi patch to the VideoPlayer.cpp) and re-compiled v9.0.3. The compile goes thru as normal, but my S905x boot will not boot with this new version - just hangs forever at the box logo. It boots with stock version of v9.0.3. I checked out tag 9.0.3 and copied my patch to the kodi patch folder. I’ve done this in the past without any such issues.

I use command PROJECT=Amlogic ARCH=arm make image.

Has anything changed recently in how builds are done? The patch I’m applying is this. It fixes the audio silence when resuming video where the previous keyframe is significantly before the resume point. The patch really does work. :slightly_smiling_face: This issue just “bugs” me and I notice it a lot without the patch applied.
kodi-ml-001-ml-fix-audio-resume.patch (526 Bytes)

I had previously reported this bug on LibreELEC forum (this issue only occurs on LE or CE, and not Windows or Android, as far as I know) here:- https://forum.libreelec.tv/thread/14657-possible-solution-audio-resume-problem-with-libreelec-9-0-issue-not-present-in-l/

I never received any responses, hence the decision to fix it and build myself.
TIA.

Hi,

The issue is purely with the boot of the modded build - the compile is fine and the change is reflected in the kodi source. I believe that even though I only want to change one line of source code that I have to rebuild from scratch - anyhow, as I say, everything looks fine on my end - just that it won’t boot - just box logo freezes.

I’m hoping something has changed, as I have done this for LibreELEC Allwinner and Rockchip (they have the same issue) and they boot fine. It always worked for me with CoreELEC until this last time. Maybe there is an extra parameter on the command like “UBOOT_SYSTEM=???” or something.

AFAIK, this bug has been ignored - it’s not noticeable most of the time - but I have several videos where the “gap” between previous keyframe and the resume point is up to 8 seconds - so that meant up to 8 seconds of missing audio. (The link to the bug report on the LE site goes into detail about that with a sample showing the problem).

I’m surprised it hasn’t been addressed by LE as the fix is very simple and works - I have used it on LE and CE on Amlogic, Rockchip and Allwinner boxes.

PROJECT=Amlogic make image
Did you try to open PR directly on xbmc github if it correct?

Thanks,

I’m trying the build again now.

The issue that the patch fixes does not occur on Windows 10 or Android - only on LE/CE. I would be surprised if kodi would accept it in that case - what do you think?

This line was added here to fix another issue:


So it possible some other fix required
You can try to repeat issue in LE and open issue with LE logs :grinning:

that’s the exact same change I am undoing to fix it for LE/CE. I guess, when they tested it, they just tested it on Windows and Android?

All the debug logs are on the LE website - the link earlier in the post. Should I just point kodi to that link?

I can confirm that issue they fixed was on CE too in some early builds. So some other patch required.
You can try, but it’s better to use Leia 18.3 logs if possible…
Also you need to follow their issue template.

Do you notice the issue in your resumption of video playback. It all depends on the gap between video keyframes. My sample shows it very clearly, but it is not the norm.

BTW, just tried rebuilding with “PROJECT=Amlogic make image” but still no boot. Do I have to clean my build library or just the u-boot section?

It’s better to make clean build if you previous one was 9.0.3 or before, in u-boot no changes for 3.14 builds
I don’t have possibility to test right now, but yes I sometimes have 1 seconds delay before audio starts, but not 7 seconds

I think it depends on content. The fewer keyframes there are the more delay there will be.

I’m putting together a problem report for kodi. I’ll post the link here when it’s done.

TIA

Kodi PR here:-

“PROJECT=Amlogic make image” with a clean build.

That fixed it thanks.